summaryrefslogtreecommitdiff
path: root/dev-libs/libnl/libnl-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libnl/libnl-9999.ebuild')
-rw-r--r--dev-libs/libnl/libnl-9999.ebuild17
1 files changed, 13 insertions, 4 deletions
diff --git a/dev-libs/libnl/libnl-9999.ebuild b/dev-libs/libnl/libnl-9999.ebuild
index 67eba8f4740d..b7e772377e97 100644
--- a/dev-libs/libnl/libnl-9999.ebuild
+++ b/dev-libs/libnl/libnl-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=8
DISTUTILS_OPTIONAL=1
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit autotools distutils-r1 multilib-minimal
LIBNL_P=${P/_/-}
@@ -31,18 +31,20 @@ RESTRICT="!test? ( test )"
RDEPEND="python? ( ${PYTHON_DEPS} )"
DEPEND="${RDEPEND}"
-BDEPEND="${RDEPEND}
+BDEPEND="
+ ${RDEPEND}
sys-devel/bison
sys-devel/flex
python? (
${DISTUTILS_DEPS}
dev-lang/swig
)
- test? ( dev-libs/check )"
+ test? ( dev-libs/check )
+"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
MULTILIB_WRAPPED_HEADERS=(
- # we do not install CLI stuff for non-native
+ # We do not install CLI stuff for non-native
/usr/include/libnl3/netlink/cli/addr.h
/usr/include/libnl3/netlink/cli/class.h
/usr/include/libnl3/netlink/cli/cls.h
@@ -58,6 +60,10 @@ MULTILIB_WRAPPED_HEADERS=(
/usr/include/libnl3/netlink/cli/utils.h
)
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.8.0-printf-non-bash.patch
+)
+
src_prepare() {
default
@@ -71,6 +77,9 @@ src_prepare() {
}
multilib_src_configure() {
+ # bug #884277
+ export YACC=yacc.bison
+
ECONF_SOURCE="${S}" econf \
$(multilib_native_use_enable utils cli) \
$(use_enable debug)