summaryrefslogtreecommitdiff
path: root/dev-libs/liborcus/liborcus-0.15.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/liborcus/liborcus-0.15.4.ebuild')
-rw-r--r--dev-libs/liborcus/liborcus-0.15.4.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/dev-libs/liborcus/liborcus-0.15.4.ebuild b/dev-libs/liborcus/liborcus-0.15.4.ebuild
index 0d5789e0eb5e..999baa80ea0f 100644
--- a/dev-libs/liborcus/liborcus-0.15.4.ebuild
+++ b/dev-libs/liborcus/liborcus-0.15.4.ebuild
@@ -4,22 +4,24 @@
EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
-inherit python-single-r1
+inherit autotools python-single-r1
DESCRIPTION="Standalone file import filter library for spreadsheet documents"
HOMEPAGE="https://gitlab.com/orcus/orcus/blob/master/README.md"
if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://gitlab.com/orcus/orcus.git"
- inherit git-r3 autotools
+ inherit git-r3
else
SRC_URI="https://kohei.us/files/orcus/src/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+ KEYWORDS="amd64 ~arm arm64 ~ppc ~ppc64 ~x86"
fi
LICENSE="MIT"
SLOT="0/0.15" # based on SONAME of liborcus.so
-IUSE="python +spreadsheet-model static-libs tools"
+IUSE="python +spreadsheet-model tools"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="
dev-libs/boost:=[zlib(+)]
@@ -31,7 +33,7 @@ DEPEND="${RDEPEND}
dev-util/mdds:1/1.5
"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+PATCHES=( "${FILESDIR}/${P}-bashism.patch" ) # bug 723130
pkg_setup() {
use python && python-single-r1_pkg_setup
@@ -39,15 +41,15 @@ pkg_setup() {
src_prepare() {
default
- [[ ${PV} == *9999 ]] && eautoreconf
+ eautoreconf
}
src_configure() {
local myeconfargs=(
+ --disable-static
--disable-werror
$(use_enable python)
$(use_enable spreadsheet-model)
- $(use_enable static-libs static)
$(use_with tools)
)
econf "${myeconfargs[@]}"