summaryrefslogtreecommitdiff
path: root/dev-libs/libpeas
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libpeas')
-rw-r--r--dev-libs/libpeas/Manifest4
-rw-r--r--dev-libs/libpeas/files/libpeas-1.14.0-lua.pc.patch18
-rw-r--r--dev-libs/libpeas/libpeas-1.20.0-r1.ebuild84
-rw-r--r--dev-libs/libpeas/metadata.xml13
4 files changed, 119 insertions, 0 deletions
diff --git a/dev-libs/libpeas/Manifest b/dev-libs/libpeas/Manifest
new file mode 100644
index 000000000000..c6592da9cfdf
--- /dev/null
+++ b/dev-libs/libpeas/Manifest
@@ -0,0 +1,4 @@
+AUX libpeas-1.14.0-lua.pc.patch 553 BLAKE2B a86596d6c76e22e3e947709db226a47110f0964ae493d4fd16e506f4666de5fd5214d431a5109ffb0b68a6743bf2aa89aba84b63fabe4e402ac491be01479743 SHA512 ead06352498ff82a4520d4a7ed7b5d03e2d0adcdf2025413851b8385bfdd691c938b456b555d2214ec2dc7b95708f306149d6f1cfa7c5b03ad28a1c90c873349
+DIST libpeas-1.20.0.tar.xz 557872 BLAKE2B c10cd85ff6f15f2124541aba3b437e3216322647e36f93a2202df14aebda7c35896a5f77a40ddcd5a5f0300df11c274334cc3a8dfba3fe2745e0b364cb7eac4c SHA512 b3ddebf65e1a76493b5cd5150f60c13597c90398eea16c002e51d25449a595f7591bd0ccd1214ca3a8cbce724eb10f38a316e8c95092442034c048bc95cfdbf4
+EBUILD libpeas-1.20.0-r1.ebuild 2190 BLAKE2B d714b8b30bb27d3587ab8879e94265a72acc6279adc5642d969bc42f87ba5746636ded6b322f55e1b4eae04a82b038b79f7fca0874293161b6b897d12521544c SHA512 647363247a0a2baaf94ccf252f3cda514d147171123aaf123fa83104cde3e41159a9ecc6c3019548efc4249fb1e21d4185a2f00fddf003bee43edf00d7925e22
+MISC metadata.xml 415 BLAKE2B c3e3dc9746663cd67cfb3a1b2e765bf5da73f9db2669ff7003b5e77ccbbe686780dd181727c3dd3d3f4c5f6e312daa1f36901896ff843cb81c687853340ef680 SHA512 4bf99a5c542cab95dadcf6db8aecbefa0be453f8851c2222ee698eec38c221f3b45b2ead6f87dd1d1ec5a233ba73054cf3b3d7b92d12ff4d88ee04a2057c50ea
diff --git a/dev-libs/libpeas/files/libpeas-1.14.0-lua.pc.patch b/dev-libs/libpeas/files/libpeas-1.14.0-lua.pc.patch
new file mode 100644
index 000000000000..c46cbee242e5
--- /dev/null
+++ b/dev-libs/libpeas/files/libpeas-1.14.0-lua.pc.patch
@@ -0,0 +1,18 @@
+Gentoo currently uses unversioned lua:0 - lua.pc instad of lua5.1.pc, /usr/bin/lua instead of /usr/bin/lua5.1
+
+diff --git a/configure.ac b/configure.ac
+index 810a288..51ca607 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -305,9 +305,9 @@ else
+ fi
+
+ if test "x$found_lua51" != "xyes"; then
+- PKG_CHECK_EXISTS([lua5.1 >= $LUA51_REQUIRED], [
++ PKG_CHECK_EXISTS([lua >= $LUA51_REQUIRED], [
+ found_lua51=yes
+- with_lua51=lua5.1
++ with_lua51=lua
+ ], [
+ found_lua51=no
+ ])
diff --git a/dev-libs/libpeas/libpeas-1.20.0-r1.ebuild b/dev-libs/libpeas/libpeas-1.20.0-r1.ebuild
new file mode 100644
index 000000000000..ead15aa6969b
--- /dev/null
+++ b/dev-libs/libpeas/libpeas-1.20.0-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+
+inherit autotools eutils gnome2 multilib python-single-r1 virtualx
+
+DESCRIPTION="A GObject plugins library"
+HOMEPAGE="https://developer.gnome.org/libpeas/stable/"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
+
+IUSE="+gtk glade lua luajit +python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ >=dev-libs/glib-2.38:2
+ >=dev-libs/gobject-introspection-1.39:=
+ glade? ( >=dev-util/glade-3.9.1:3.10 )
+ gtk? ( >=x11-libs/gtk+-3:3[introspection] )
+ lua? (
+ >=dev-lua/lgi-0.9.0
+ luajit? ( >=dev-lang/luajit-2:2 )
+ !luajit? ( =dev-lang/lua-5.1*:0 ) )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-python/pygobject-3.2:3[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.11
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+
+ dev-libs/gobject-introspection-common
+ gnome-base/gnome-common
+"
+# eautoreconf needs gobject-introspection-common, gnome-common
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # Gentoo uses unversioned lua - lua.pc instad of lua5.1.pc, /usr/bin/lua instead of /usr/bin/lua5.1
+ eapply "${FILESDIR}"/${PN}-1.14.0-lua.pc.patch
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # Wtf, --disable-gcov, --enable-gcov=no, --enable-gcov, all enable gcov
+ # What do we do about gdb, valgrind, gcov, etc?
+ local myconf=(
+ $(use_enable glade glade-catalog)
+ $(use_enable gtk)
+ --disable-static
+
+ # py2 not supported anymore
+ --disable-python2
+ $(use_enable python python3)
+
+ # lua
+ $(use_enable lua lua5.1)
+ $(use_enable $(usex luajit lua luajit) luajit)
+ )
+
+ gnome2_src_configure "${myconf[@]}"
+}
+
+src_test() {
+ # This looks fixed since 1.18.0:
+ #
+ # FIXME: Tests fail because of some bug involving Xvfb and Gtk.IconTheme
+ # DO NOT REPORT UPSTREAM, this is not a libpeas bug.
+ # To reproduce:
+ # >>> from gi.repository import Gtk
+ # >>> Gtk.IconTheme.get_default().has_icon("gtk-about")
+ # This should return True, it returns False for Xvfb
+ virtx emake check
+}
diff --git a/dev-libs/libpeas/metadata.xml b/dev-libs/libpeas/metadata.xml
new file mode 100644
index 000000000000..f955af2bfc30
--- /dev/null
+++ b/dev-libs/libpeas/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+ <use>
+ <flag name="glade">Install the glade catalog</flag>
+ <flag name="python">Build support for loading <pkg>dev-lang/python</pkg>
+ plugins</flag>
+ </use>
+</pkgmetadata>