summaryrefslogtreecommitdiff
path: root/dev-libs/libphonenumber/libphonenumber-8.12.37.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libphonenumber/libphonenumber-8.12.37.ebuild')
-rw-r--r--dev-libs/libphonenumber/libphonenumber-8.12.37.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-libs/libphonenumber/libphonenumber-8.12.37.ebuild b/dev-libs/libphonenumber/libphonenumber-8.12.37.ebuild
deleted file mode 100644
index f613d7a4ab4b..000000000000
--- a/dev-libs/libphonenumber/libphonenumber-8.12.37.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-CMAKE_MAKEFILE_GENERATOR="emake" # broken w/ ninja
-inherit cmake
-
-DESCRIPTION="Library for parsing, formatting, and validating international phone numbers"
-HOMEPAGE="https://github.com/google/libphonenumber"
-SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-CMAKE_USE_DIR="${WORKDIR}"/${P}/cpp
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 arm64 ~ppc64 x86"
-IUSE="test"
-
-RESTRICT="test !test? ( test )"
-
-DEPEND="
- dev-libs/icu:=
- dev-libs/protobuf:=
- dev-libs/boost:=
-"
-RDEPEND="${DEPEND}"
-BDEPEND="
- virtual/pkgconfig
- test? ( dev-cpp/gtest )
-"
-
-PATCHES=(
- # it is either this, or disable BUILD_GEOCODER
- # https://github.com/google/libphonenumber/pull/2556
- "${FILESDIR}"/${P}-cmake.patch
- # see also https://github.com/google/libphonenumber/pull/2459
- # using a stripped-down patch w/ BUILD_TESTING
- "${FILESDIR}"/${P}-testing.patch
-)
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_STATIC_LIB=OFF
- -DBUILD_TESTING=$(usex test)
- -DREGENERATE_METADATA=OFF # avoid JRE dependency
- )
- cmake_src_configure
-}