summaryrefslogtreecommitdiff
path: root/dev-libs/libpipeline
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libpipeline')
-rw-r--r--dev-libs/libpipeline/Manifest2
-rw-r--r--dev-libs/libpipeline/libpipeline-1.5.8.ebuild23
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-libs/libpipeline/Manifest b/dev-libs/libpipeline/Manifest
index 97399cc27de0..e654232db77c 100644
--- a/dev-libs/libpipeline/Manifest
+++ b/dev-libs/libpipeline/Manifest
@@ -1,3 +1,5 @@
DIST libpipeline-1.5.7.tar.gz 977735 BLAKE2B b8f9ff6886f8df12e3fefbfaa0cbcb1e07d7baaa8a1dfcf4bc01c17c6632b8c6a40e55395f1e4870ca391eefb1535ebbc3931fcdee51cf5f4293741e437a2f25 SHA512 bb3be954f5d826cef805f85d65759fb197c31adf80d92360c7d0caa486e0d4877510681390ca01c028b6e805f968f14e8bf4b3eca02e429529031787e7f14d84
+DIST libpipeline-1.5.8.tar.gz 1070254 BLAKE2B 1feb1a9493fd0850b4e3e446619e7e042bd97d8c0bbb3e13a91d90d6cde3ca2c17fb8a3ca256f65291dadc4d8703ad5d3a795839bf8280adc4547b3ec3d2da7d SHA512 0ae94df4bd508f0e664fa5430687d64904c60d69d9565c18cacb70251f8653cb7c571325d1406c859fdd149048adce8c4b3bf028573064496d7da3436e27b9b0
EBUILD libpipeline-1.5.7.ebuild 622 BLAKE2B fc8436f9f51fd9541e29ded1d7806b6e972ca48c0c87021f2969dc0710b972e770c9e5ef5a153f8e9f5a407f26506467aaa545d68b5a47867318d5552cb8262a SHA512 eeb56813ad59a7b62a03b3bd861941bc5dc2b9399ccf6caa5299696d67d054a468ebea45d21aa8169a19cb75bea2325b1294deeb7cbab8d6b816fc542eda3cba
+EBUILD libpipeline-1.5.8.ebuild 630 BLAKE2B 45aa99126ee120b8e4ecf3af9e1835729a90caf6d3f6902785c2de8e2f26d80bd94b8c7e081f0df9bc1e2508b28604da41d68de4e53444803a799da45a6c7f20 SHA512 f36925ab42e72437b4ebdbf0e601598b422f35bf1e9d424fe72b95fcb6afdd4615f38addf98739389f96758f862b70ed3c078d8bd194d3c81b5d10f5d5051275
MISC metadata.xml 346 BLAKE2B 4d9a2da649bd11799ca9979ac16e9019969e144505569d19f74a635570b02fc10b76b9b7e72fcd1f839cd5af0c09664830dd04793611859b6a27ac8adea200fc SHA512 519217cee8afaf715c65e1e91da36943539e91cdb83a71f5023be00caee984ade4b296a0cf894afca69806f6024d78c1349507ccdd822580ddce734936244d56
diff --git a/dev-libs/libpipeline/libpipeline-1.5.8.ebuild b/dev-libs/libpipeline/libpipeline-1.5.8.ebuild
new file mode 100644
index 000000000000..996db35e8502
--- /dev/null
+++ b/dev-libs/libpipeline/libpipeline-1.5.8.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A pipeline manipulation library"
+HOMEPAGE="https://libpipeline.nongnu.org/"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-libs/check )"
+BDEPEND="virtual/pkgconfig"
+
+src_install() {
+ default
+
+ find "${ED}" -type f -name "*.la" -delete || die
+}