summaryrefslogtreecommitdiff
path: root/dev-libs/libratbag/libratbag-0.16.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libratbag/libratbag-0.16.ebuild')
-rw-r--r--dev-libs/libratbag/libratbag-0.16.ebuild17
1 files changed, 12 insertions, 5 deletions
diff --git a/dev-libs/libratbag/libratbag-0.16.ebuild b/dev-libs/libratbag/libratbag-0.16.ebuild
index b46974b3385e..9b8dda025eb3 100644
--- a/dev-libs/libratbag/libratbag-0.16.ebuild
+++ b/dev-libs/libratbag/libratbag-0.16.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit meson python-single-r1 systemd udev
@@ -25,7 +25,12 @@ BDEPEND="
${PYTHON_DEPS}
dev-lang/swig
virtual/pkgconfig
- doc? ( app-doc/doxygen )
+ doc? (
+ $(python_gen_cond_dep '
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ ')
+ )
test? (
dev-libs/check
dev-libs/gobject-introspection
@@ -39,9 +44,11 @@ BDEPEND="
RDEPEND="
${PYTHON_DEPS}
acct-group/plugdev
+ dev-libs/glib:2
dev-libs/json-glib
dev-libs/libevdev
- virtual/libudev
+ dev-libs/libunistring:=
+ virtual/libudev:=
$(python_gen_cond_dep '
dev-python/pygobject:3[${PYTHON_USEDEP}]
dev-python/python-evdev[${PYTHON_USEDEP}]