summaryrefslogtreecommitdiff
path: root/dev-libs/libstrl/libstrl-0.5.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libstrl/libstrl-0.5.1.ebuild')
-rw-r--r--dev-libs/libstrl/libstrl-0.5.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/libstrl/libstrl-0.5.1.ebuild b/dev-libs/libstrl/libstrl-0.5.1.ebuild
new file mode 100644
index 000000000000..2515eaba0880
--- /dev/null
+++ b/dev-libs/libstrl/libstrl-0.5.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit autotools-utils multilib
+
+DESCRIPTION="Compat library for functions like strlcpy(), strlcat(), strnlen(), getline()"
+HOMEPAGE="http://ohnopub.net/~ohnobinki/libstrl/"
+SRC_URI="ftp://mirror.ohnopub.net/mirror/${P}.tar.bz2"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x64-macos"
+IUSE="doc static-libs test"
+
+# block various versions of opendkim for bug #454938 and bug #441790.
+DEPEND="doc? ( app-doc/doxygen )
+ test? ( dev-libs/check )
+ !=mail-filter/opendkim-2.7.0 !=mail-filter/opendkim-2.7.1 !=mail-filter/opendkim-2.7.2"
+RDEPEND="!=mail-filter/opendkim-2.7.0 !=mail-filter/opendkim-2.7.1 !=mail-filter/opendkim-2.7.2"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with doc doxygen)
+ $(use_with test check)
+ )
+
+ autotools-utils_src_configure
+}