summaryrefslogtreecommitdiff
path: root/dev-libs/libuev/libuev-2.4.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libuev/libuev-2.4.1.ebuild')
-rw-r--r--dev-libs/libuev/libuev-2.4.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-libs/libuev/libuev-2.4.1.ebuild b/dev-libs/libuev/libuev-2.4.1.ebuild
new file mode 100644
index 000000000000..919da37412e8
--- /dev/null
+++ b/dev-libs/libuev/libuev-2.4.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Lightweight event loop library for Linux epoll() family APIs"
+HOMEPAGE="https://github.com/troglobit/libuev"
+SRC_URI="https://github.com/troglobit/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="static-libs"
+
+src_configure() {
+ econf --enable-static=$(usex static-libs)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+ rm "${ED}"/usr/share/doc/${PF}/LICENSE || die
+}