summaryrefslogtreecommitdiff
path: root/dev-libs/libxmlb
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libxmlb')
-rw-r--r--dev-libs/libxmlb/Manifest4
-rw-r--r--dev-libs/libxmlb/libxmlb-0.3.21.ebuild73
-rw-r--r--dev-libs/libxmlb/metadata.xml6
3 files changed, 82 insertions, 1 deletions
diff --git a/dev-libs/libxmlb/Manifest b/dev-libs/libxmlb/Manifest
index 78a1a642ac9c..5e4064c8fad4 100644
--- a/dev-libs/libxmlb/Manifest
+++ b/dev-libs/libxmlb/Manifest
@@ -1,3 +1,5 @@
DIST libxmlb-0.3.19.tar.gz 131490 BLAKE2B 1455e14a90f29865f304b16cbf0355966e7fd0766f8033cb2b2bc9fe28ad0a1266c1e06faaeb3677a683be56bc2fd9a64094d958f00358292fae55949229ab9a SHA512 07db2e99b2f78f6e99cccbf5ca250978955d5a9bf18aaa675b2292d1df438fc3f98a5d0e8ddcfa41e686782f35947fe92b54b520b4e6e278d6e5c871e7491271
+DIST libxmlb-0.3.21.tar.gz 132251 BLAKE2B 07140d840b7b807cff0c555c18ab33d9bd087d4af4e0bb47088b264a7d9dfff8929ab2820341ec99882c7239d77ee135b2c3592f465667c3bd62aa59396cf0f1 SHA512 5583e547e2e9077552902b5da87a83bfe4a9c723dbd0350b33014b34936feb4fa15fc4b4fedf23ce2aa2c870df57facc376b8549f7d03714df70fe5e738f61c8
EBUILD libxmlb-0.3.19.ebuild 1646 BLAKE2B 93ddb0bc0abda195ecb82e1db6aac19b385af502e8874b72d013b003f1e5d7083ee4e6dd434835266c0a766ff0c34488f25ebf2134cc0432747e1026e17fdc7f SHA512 7a9cca905f26201aa6424b2bdb60de683bb078f8c79139d1d66430c510daedd0768a8b9b948bc93dbd089564fb1c9ea51890d8b1dfbad4a39f9400e19738eb65
-MISC metadata.xml 326 BLAKE2B e1946e0e73f0daf43e442294f2a795e8005d8ed3e15a76c8737c824cfc4f7b7e89417a129c32aad675ba423afe8aa41c15535bbfe519ea53443eab7077eeddee SHA512 3bacab766832b0080685dab70dbb6019d3a9af6f056af6e4d4c3fa4bea249e7379730ed6a5a45b3555e9e6d0d52c735b212b714c772b224c00f8c3c28845cef1
+EBUILD libxmlb-0.3.21.ebuild 1584 BLAKE2B 1f75a1eae7c66991deff4899fdd9f762d34f660d080af409927f2e49d87362a8e0e27ba9b8754b4ea4ed04b079c768eef7a7cd22ca60a36ce127d2f59c1ccf40 SHA512 8148ec23bcf85b465321438389c2d1d2b8644965622d52d88e7ec34531032e606d8b280207cc9ecf453e6b82200b1b3642a53248d7ec240270099e80bbc0348e
+MISC metadata.xml 599 BLAKE2B 9b77f8a70b4ee01f5c760d0c03fc4c916fd3ef673cae46e50201f84667ba46e4ee0153ca956cbdbcf380f1750e53545478caab22a9c3cbec06bf81c4e4cfb200 SHA512 3367cff14cc33a1a380aaa7b42569fe06f3d06baea13f5861095bc581b9347f8ffa69387d1a4dc5ab8d4c1b9ee1639484cb1e874fafd594a0762c82d6f7d7176
diff --git a/dev-libs/libxmlb/libxmlb-0.3.21.ebuild b/dev-libs/libxmlb/libxmlb-0.3.21.ebuild
new file mode 100644
index 000000000000..069a75637030
--- /dev/null
+++ b/dev-libs/libxmlb/libxmlb-0.3.21.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit meson python-any-r1
+
+DESCRIPTION="Library to help create and query binary XML blobs"
+HOMEPAGE="https://github.com/hughsie/libxmlb"
+SRC_URI="https://github.com/hughsie/libxmlb/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="LGPL-2.1+"
+SLOT="0/2" # libxmlb.so version
+
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="doc introspection +lzma stemmer test +zstd"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/glib:2
+ lzma? ( app-arch/xz-utils )
+ stemmer? ( dev-libs/snowball-stemmer:= )
+ zstd? ( app-arch/zstd:= )
+"
+DEPEND="
+ ${RDEPEND}
+ doc? ( dev-util/gtk-doc )
+ introspection? ( dev-libs/gobject-introspection )
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+ introspection? (
+ $(python_gen_any_dep 'dev-python/setuptools[${PYTHON_USEDEP}]')
+ )
+"
+DOCS=( NEWS README.md )
+
+python_check_deps() {
+ if use introspection ; then
+ python_has_version -b "dev-python/setuptools[${PYTHON_USEDEP}]"
+ else
+ return 0
+ fi
+}
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature lzma)
+ $(meson_feature zstd)
+ $(meson_use doc gtkdoc)
+ $(meson_use introspection)
+ $(meson_use stemmer)
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ if use test; then
+ # Preventing tests from being installed in the first place is a moving target,
+ # just axe them all afterwards.
+ rm -r "${ED}"/usr/{libexec,share}/installed-tests || die
+ fi
+}
diff --git a/dev-libs/libxmlb/metadata.xml b/dev-libs/libxmlb/metadata.xml
index 3a9fb808862a..90bc0bf67d7c 100644
--- a/dev-libs/libxmlb/metadata.xml
+++ b/dev-libs/libxmlb/metadata.xml
@@ -6,6 +6,12 @@
<flag name="stemmer">Enable language stemming support</flag>
</use>
<upstream>
+ <maintainer status="active"> <!-- see MAINTAINERS -->
+ <name>Richard Hughes</name>
+ <email>richard@hughsie.com</email>
+ </maintainer>
+ <bugs-to>https://github.com/hughsie/libxmlb/issues</bugs-to>
+ <changelog>https://github.com/hughsie/libxmlb/releases</changelog>
<remote-id type="github">hughsie/libxmlb</remote-id>
</upstream>
</pkgmetadata>