summaryrefslogtreecommitdiff
path: root/dev-libs/npth/npth-1.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/npth/npth-1.3.ebuild')
-rw-r--r--dev-libs/npth/npth-1.3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-libs/npth/npth-1.3.ebuild b/dev-libs/npth/npth-1.3.ebuild
new file mode 100644
index 000000000000..1b6b254ae4ca
--- /dev/null
+++ b/dev-libs/npth/npth-1.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit libtool
+
+DESCRIPTION="New GNU Portable Threads Library"
+HOMEPAGE="https://git.gnupg.org/cgi-bin/gitweb.cgi?p=npth.git"
+SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+src_prepare() {
+ default
+ elibtoolize # for Solaris shared library
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}