summaryrefslogtreecommitdiff
path: root/dev-libs/ntl
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/ntl')
-rw-r--r--dev-libs/ntl/Manifest1
-rw-r--r--dev-libs/ntl/ntl-11.5.1-r3.ebuild86
2 files changed, 0 insertions, 87 deletions
diff --git a/dev-libs/ntl/Manifest b/dev-libs/ntl/Manifest
index c195a11e7346..6c542ac9da9a 100644
--- a/dev-libs/ntl/Manifest
+++ b/dev-libs/ntl/Manifest
@@ -1,4 +1,3 @@
DIST ntl-11.5.1.tar.gz 2304103 BLAKE2B 92284383451c7a810f7ee8d9a82836695d19d2a2e46b71c8c60b00acb77f4b4d3bad5497a309616a3e3188567d20203f5ad31295130ab0f3ace08417188c9fda SHA512 cf1f642b8a0f9cdc6dda888e07183817dc67ff494e56a852053aeb15b3d2a0e61fbc05824779c5d1f20b8115fba6f97266acf7e0b0b527c25df5989c86d5928f
-EBUILD ntl-11.5.1-r3.ebuild 2558 BLAKE2B 18998bc75528ff91ee88c6932ae2982d898940fbf0d9e344bab1f445e81cd8899c854816222ed47409543b9d700bb5d0ebbd0dbba9d1dd6bf20af445e9bc2124 SHA512 e308a4c7739df1a8c52d7aa3714a81701afd2d7049c2ea9db4b9580ff51e267d3ac17016275b55b8bc51ed6a3e863bfb7fb42a1746011a500006c9322380e23b
EBUILD ntl-11.5.1-r4.ebuild 2418 BLAKE2B 9bc35977c223307782c86df8953e7576e94fd4c8f1295679f7cf5c6db27ac09080e3b013fe722d0d2eb91e99c5e367ecf9b46cd5ebfb9154f93f8de37fa48ed1 SHA512 fa49c887ae2b1a049f3324a408cf27a97c859eb28e4464b8d6a24285de0019615744828be165b39976860daada6e3b447c80feb837346642f3f1f09c6a308921
MISC metadata.xml 628 BLAKE2B 12ef87b42f60ca7bd5f91708c96471378481bfdc911d638a550608f62928a40e879431028f6e578047b79749e0c8307a4075520434191099adece5a771e5c27f SHA512 724f4bc44918ec49f4bb30ef7c9cc6de8c4243845a2a4c7d8c73db6f1db8fa548ad0932f324deea2002ea35cb7b410120cb86a0743bb2d6765fcd987593fcd84
diff --git a/dev-libs/ntl/ntl-11.5.1-r3.ebuild b/dev-libs/ntl/ntl-11.5.1-r3.ebuild
deleted file mode 100644
index b4e6ec7eadc4..000000000000
--- a/dev-libs/ntl/ntl-11.5.1-r3.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit toolchain-funcs gnuconfig
-
-DESCRIPTION="High-performance and portable C++ number theory library"
-HOMEPAGE="https://www.shoup.net/ntl/ https://github.com/libntl/ntl"
-SRC_URI="https://www.shoup.net/ntl/${P}.tar.gz"
-
-LICENSE="LGPL-2.1+"
-SLOT="0/44"
-KEYWORDS="amd64 ~arm64 ~loong ppc ~ppc64 ~riscv x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-IUSE="doc threads cpu_flags_x86_avx2"
-
-BDEPEND="dev-lang/perl"
-DEPEND="dev-libs/gmp:0=
- dev-libs/gf2x
- threads? ( >=dev-libs/gf2x-1.2 )"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${P}/src"
-
-DOCS=( "${WORKDIR}/${P}"/README )
-
-src_unpack() {
- default
- gnuconfig_update "${S}/libtool-origin/"
-}
-
-src_configure() {
- # The DoConfig script builds its own libtool, but doesn't
- # really try to set up the build environment (bug 718892).
- export CC="$(tc-getCC)"
- export CXX="$(tc-getCXX)"
-
- # The "AVX2" detection within NTL does more than just detect AVX2;
- # it also checks that (for example) the size of a "long" is 64 bits.
- # If we try to enable the AVX FFT (based on the avx2 cpu flag) and
- # if NTL determines that AVX2 is unusable for some other reason,
- # then the build will fail (bug 815775). To work around that, we
- # disable the AVX FFT on x86 entirely. This still isn't perfect, but
- # it should fix the cases we know about.
- local avx_fft=$(usex cpu_flags_x86_avx2 on off)
- use x86 && avx_fft=off
-
- # Currently the build system can build a static library or both
- # static and shared libraries, but not only shared libraries. The
- # name NTL_GMP_LIP is *not* a typo.
- perl DoConfig \
- PREFIX="${EPREFIX}"/usr \
- LIBDIR="${EPREFIX}"/usr/$(get_libdir) \
- CXXFLAGS="${CXXFLAGS}" \
- CPPFLAGS="${CPPFLAGS}" \
- LDFLAGS="${LDFLAGS}" \
- CXX="$(tc-getCXX)" \
- AR="$(tc-getAR)" \
- RANLIB="$(tc-getRANLIB)" \
- SHARED=on \
- NTL_GMP_LIP=on \
- NTL_GF2X_LIB=on \
- NTL_THREADS=$(usex threads on off) \
- NTL_ENABLE_AVX_FFT="${avx_fft}" \
- NATIVE=off \
- || die "DoConfig failed"
-
- if use doc; then
- DOCS+=( "${WORKDIR}/${P}"/doc/*.txt )
- HTML_DOCS=( "${WORKDIR}/${P}"/doc/*.html "${WORKDIR}/${P}"/doc/*.gif )
- fi
-
- # 780534 - Required for rlibtool so it can find the generated libtool
- ln -sf libtool-build/libtool . || die
-}
-
-src_install() {
- default
- find "${ED}" -name '*.la' -delete || die
-
- # Use rm -f because the static archive may not be created when
- # using (for example) slibtool-shared.
- rm -f "${ED}/usr/$(get_libdir)"/libntl.a || die
-
- rm -r "${ED}"/usr/share/doc/NTL || die
-}