summaryrefslogtreecommitdiff
path: root/dev-libs/poco
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/poco')
-rw-r--r--dev-libs/poco/Manifest2
-rw-r--r--dev-libs/poco/poco-1.9.0-r2.ebuild35
2 files changed, 18 insertions, 19 deletions
diff --git a/dev-libs/poco/Manifest b/dev-libs/poco/Manifest
index 4a4fde2b25bd..9af3bb709485 100644
--- a/dev-libs/poco/Manifest
+++ b/dev-libs/poco/Manifest
@@ -1,4 +1,4 @@
AUX poco-1.7.2-iodbc-incdir.patch 321 BLAKE2B 640c0b69e8c925d48da6f2bfc59cd2c77a02662ad1d8d447bb8c7ca23234ca1859c4aa9497d5703ef5f675d9096606254a9142770c6fffa4334cf71b1ca6953f SHA512 f3a0b4032fd4f71f0281d58c00241b1cd2f92da1a23a8501c420949621167d1fc7e2a2ed3ec48b6f75d35569f6443e3391eaf19a8c8fbd17e24d1cbd9ffd892d
DIST poco-1.9.0.tar.gz 10012966 BLAKE2B 98848e87008c71dc5131dbd1c2b17afc414074a3e26237918baf231b4e56ce3d69347cf7a3017715895f4ee56a428672fcb804fb3c732da0000ccc9790b0081d SHA512 de2346d62b2e89ba04abe62a83f6ede7a496e80bcbe53a880a1aa8e87a8ebd9a430dd70fdc6aada836bb1021c6df21375fd0cbcf62dbb6e29a2f65d6d90cf2b9
-EBUILD poco-1.9.0-r2.ebuild 3850 BLAKE2B 4a527b3b1a416c97f9cf4a9b093f262cbd9243e3e24d8af4a868b2fe55e0adb45d21290a6735a26a364572165a2518bc8d50eff5091ce883169b2d223ca74a8a SHA512 e8fc21f64b36e82b064648f6108ae6e9c64117bde3f5d092d49ffbcdd704c90d71d8d121756c06eed8c82cf8e4e75c3a5b7f966ebccec89a76f0957091287f3d
+EBUILD poco-1.9.0-r2.ebuild 3848 BLAKE2B 997744d759075ab074b611237b98327a162eca4778e8a6cb14e6823ce4b21f182f27e2c63e10aed205c18208f43abbf0fc268d61d7cdbc4b799da0c2a563202a SHA512 7b05546ae7dfb9faa3cec811e5a7300aee3eae3f8ed74aeafa6056ac16d9a290812cf90d3796c0c24f7606f5d436f39a820d8c7ecf05a219d033ae119a631f25
MISC metadata.xml 2354 BLAKE2B c376c105867c39c9bd2fbeb553f40acd95d71307b5c89b0e2d685862fa901b06c3056ff7996b4a1bce8b70f70bad45678c6a0d41567564dc009841f520fe8b3e SHA512 9263939c5e0120e2687446859db4fbfd84072f1d1ae37cb993b1eb69c39dddc828aadf95ef9fed86f8bea65ce24e041740dd48523ad68756b45ef47454c64a8c
diff --git a/dev-libs/poco/poco-1.9.0-r2.ebuild b/dev-libs/poco/poco-1.9.0-r2.ebuild
index 0e799b657b11..f2c9dd98dac6 100644
--- a/dev-libs/poco/poco-1.9.0-r2.ebuild
+++ b/dev-libs/poco/poco-1.9.0-r2.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit cmake-utils
DESCRIPTION="C++ libraries for building network-based applications"
@@ -11,7 +12,7 @@ LICENSE="Boost-1.0"
SLOT="0"
KEYWORDS="amd64 arm x86"
-IUSE="7z cppparser +crypto +data examples +file2pagecompiler +json +pagecompiler iodbc libressl mariadb +mongodb mysql +net odbc pdf pocodoc sqlite +ssl test +util +xml +zip"
+IUSE="7z cppparser +crypto +data examples +file2pagecompiler iodbc +json libressl mariadb +mongodb mysql +net odbc +pagecompiler pdf pocodoc sqlite +ssl test +util +xml +zip"
REQUIRED_USE="
7z? ( xml )
file2pagecompiler? ( pagecompiler )
@@ -21,48 +22,48 @@ REQUIRED_USE="
odbc? ( data )
pagecompiler? ( json net util xml )
pocodoc? ( cppparser util xml )
- ssl? ( util )
sqlite? ( data )
+ ssl? ( util )
test? ( data? ( sqlite ) json util xml )
"
+BDEPEND="
+ virtual/pkgconfig
+"
RDEPEND="
>=dev-libs/libpcre-8.42
- xml? ( dev-libs/expat )
mysql? ( !mariadb? ( dev-db/mysql-connector-c:0= )
mariadb? ( dev-db/mariadb-connector-c:0= ) )
odbc? ( iodbc? ( dev-db/libiodbc )
!iodbc? ( dev-db/unixODBC ) )
+ sqlite? ( dev-db/sqlite:3 )
ssl? (
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
)
- sqlite? ( dev-db/sqlite:3 )
+ xml? ( dev-libs/expat )
zip? ( sys-libs/zlib )
"
-DEPEND="${DEPEND}
- virtual/pkgconfig
-"
+DEPEND="${RDEPEND}"
S="${WORKDIR}/${PN}-${P}-release"
PATCHES=( "${FILESDIR}/${PN}-1.7.2-iodbc-incdir.patch" )
src_prepare() {
+ cmake-utils_src_prepare
+
if use test ; then
# ignore missing tests on experimental library
# and tests requiring running DB-servers, internet connections, etc.
- sed -i \
- -e '/testsuite/d' \
+ sed -i -e '/testsuite/d' \
{Data/{MySQL,ODBC},MongoDB,Net,NetSSL_OpenSSL,PDF,Redis}/CMakeLists.txt || die
# Poco expands ~ using passwd, which does not match $HOME in the build environment
- sed -i \
- -e '/CppUnit_addTest.*testExpand/d' \
+ sed -i -e '/CppUnit_addTest.*testExpand/d' \
Foundation/testsuite/src/PathTest.cpp || die
# ignore failing Crypto test since upstream does not seem to care,
# see https://github.com/pocoproject/poco/issues/1209
- sed -i \
- -e '/RSATest, testRSACipherLarge/d' \
+ sed -i -e '/RSATest, testRSACipherLarge/d' \
Crypto/testsuite/src/RSATest.cpp || die
fi
@@ -81,7 +82,9 @@ src_prepare() {
# Add missing directory that breaks the build
mkdir -p Encodings/testsuite/data || die
- cmake-utils_src_prepare
+ if ! use iodbc ; then
+ sed -i -e 's|iodbc||' cmake/FindODBC.cmake || die
+ fi
}
src_configure() {
@@ -111,10 +114,6 @@ src_configure() {
-DENABLE_ZIP="$(usex zip)"
)
- if ! use iodbc ; then
- sed -i -e 's|iodbc||' cmake/FindODBC.cmake || die
- fi
-
cmake-utils_src_configure
}