summaryrefslogtreecommitdiff
path: root/dev-libs/ppl/ppl-1.2-r5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/ppl/ppl-1.2-r5.ebuild')
-rw-r--r--dev-libs/ppl/ppl-1.2-r5.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/dev-libs/ppl/ppl-1.2-r5.ebuild b/dev-libs/ppl/ppl-1.2-r5.ebuild
index 2f04e7fb2e50..70d986e738f2 100644
--- a/dev-libs/ppl/ppl-1.2-r5.ebuild
+++ b/dev-libs/ppl/ppl-1.2-r5.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit autotools
+inherit autotools flag-o-matic
DESCRIPTION="The Parma Polyhedra Library for numerical analysis of complex systems"
HOMEPAGE="http://bugseng.com/products/ppl"
SRC_URI="http://bugseng.com/products/ppl/download/ftp/releases/${PV}/${P}.tar.xz
- https://dev.gentoo.org/~juippis/distfiles/tmp/ppl-1.2-r3-disable-boeing-tests.patch"
+ https://dev.gentoo.org/~juippis/distfiles/tmp/${P}-r3-disable-boeing-tests.patch"
LICENSE="GPL-3"
SLOT="0/4.14" # SONAMEs
@@ -41,6 +41,10 @@ src_prepare() {
}
src_configure() {
+ # mem_fun_ref and friends were removed in c++17, and some toolchains
+ # are beginning to default to that (bug 919850).
+ append-cxxflags -std=c++14
+
local interfaces=( c )
use cxx && interfaces+=( cxx )
econf \