summaryrefslogtreecommitdiff
path: root/dev-libs/qrosscore/qrosscore-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/qrosscore/qrosscore-9999.ebuild')
-rw-r--r--dev-libs/qrosscore/qrosscore-9999.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-libs/qrosscore/qrosscore-9999.ebuild b/dev-libs/qrosscore/qrosscore-9999.ebuild
new file mode 100644
index 000000000000..fd34067bae29
--- /dev/null
+++ b/dev-libs/qrosscore/qrosscore-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils git-r3
+
+EGIT_REPO_URI="https://github.com/0xd34df00d/Qross.git"
+
+DESCRIPTION="KDE-free version of Kross (core libraries and Qt Script backend)"
+HOMEPAGE="https://github.com/0xd34df00d/Qross"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="debug"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/designer:5
+ dev-qt/qtscript:5
+"
+DEPEND="${RDEPEND}"
+
+CMAKE_USE_DIR="${S}/src/qross"
+
+mycmakeargs=( -DUSE_QT5=ON )