summaryrefslogtreecommitdiff
path: root/dev-libs/s2n
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/s2n')
-rw-r--r--dev-libs/s2n/Manifest2
-rw-r--r--dev-libs/s2n/s2n-1.0.0.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-libs/s2n/Manifest b/dev-libs/s2n/Manifest
index 6a794206f0d8..9a82d46321b4 100644
--- a/dev-libs/s2n/Manifest
+++ b/dev-libs/s2n/Manifest
@@ -1,4 +1,6 @@
AUX s2n-0.10.21-remove_Werror.patch 1292 BLAKE2B 208aab54784a956003c0f23564d07124476149f9a36fce40c6404ea79956479ba2a589bcb75808adae67c4f50ba78ac5fb72d21429248a515c9c84bf5faf5930 SHA512 4f8cbdfeeb7dfa514750083e1be4481f5ffe1e30ff88915b5c7eff2494ae534c454da51a0c56d720be66b5ce50900135a4e17f66a517ec437a027b01c9fc0fd0
DIST s2n-0.10.21.tar.gz 6150129 BLAKE2B cf598ef02b4aa9a2a69f11a47b2a691055575b7398ba0a833081da704ebc7564d30abda5f2ad9ff9858ec2f553b1f332e913494b9e195e2a754f008bab5c11d2 SHA512 26957edf36af088af2cb355dad9281fefd9d54ce8c3c2c26f5682aee8d64338a3677aa81f3a07563b27a938cad2c57e0a86a478c9619cc93552674451d501909
+DIST s2n-1.0.0.tar.gz 6211951 BLAKE2B 3714f26ab0dbd53b878c73e0ae0abf9e8a4b85b16a62dd44a3e6264fba1afdfdd7bbffc3b38b494c5cc805b8a9dfe02009d109e308ff13b4752a56594299f374 SHA512 ab5ccc3e73e7f395ef86a5e637b9c2d18110c14b2913990d12e02286f6562497f7e9d45912e9076216e5f595d7932d58a31642e344a5e472259386983ad44bac
EBUILD s2n-0.10.21-r1.ebuild 1479 BLAKE2B 0c2e33c6e9fc25cf67e3443dd9cc6a6cfd124326cfde164c945ac692fc2a4df1f2c336ea9df285c32c2a90848de0357fbd98ec9424fc48496576c142f943c391 SHA512 f8cdf7306ebfb68d73651b6617c49e011382540c1752b5ffc3449a9fc37b57ec8015a310ec155f8c23dab3430942b4696074a4419459c4f912d946c51684c5f1
+EBUILD s2n-1.0.0.ebuild 1538 BLAKE2B 3416e37c30e9db58f9ec3159b1a81d6e0210590c95b9dbee15a6f80cd116b552d9bbf564defc51f13662454b2b9ee23ef4c46da5f9889a36d0543d3ef71ac8ed SHA512 a322374afc4dd0c277855ccc96f02d8403c57505b002d722a1927f00ae68808a8e94b4fd21433b2cba485180f8139d5142ac0f7069e0ecfac6c487ac7a57aaae
MISC metadata.xml 1568 BLAKE2B 41ed0afaba38302a1e1c2c6dee42947fb5a3221c0d58635a391193042e1d7589032722c215f3266c6771fa5097c91003e2f07166e794a801a264533f80481279 SHA512 12abec6ad35667aaae299705b1618c3fe173344a3ce4223213a437feef599afc381d7b31e8d2265429af8ae53c396e23fa673e44d666bb8910687d554f88d3d5
diff --git a/dev-libs/s2n/s2n-1.0.0.ebuild b/dev-libs/s2n/s2n-1.0.0.ebuild
new file mode 100644
index 000000000000..e5604e538393
--- /dev/null
+++ b/dev-libs/s2n/s2n-1.0.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Simple, small, fast and secure C99 implementation of the TLS/SSL protocols"
+HOMEPAGE="https://github.com/awslabs/s2n"
+SRC_URI="https://github.com/awslabs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl static-libs test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0=[static-libs=] )
+ libressl? ( dev-libs/libressl:0=[static-libs=] )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.10.21-remove_Werror.patch
+)
+
+S="${WORKDIR}/${PN}-tls-${PV}"
+
+src_prepare() {
+ cmake_src_prepare
+
+ # Fix
+ # QA Notice: The following files contain writable and executable sections (...)
+ sed \
+ -e '$a\\n#if defined(__linux__) && defined(__ELF__)\n.section .note.GNU-stack,"",%progbits\n#endif' \
+ -i "${S}"/pq-crypto/sike_r2/sikep434r2_fp_x64_asm.S || die "sed failed"
+
+ # Fix shared library building, needed for USE="test"
+ # See: https://github.com/awslabs/s2n/issues/2401
+ if use test; then
+ sed -i -e 's, -fvisibility=hidden,,' "${S}"/CMakeLists.txt || die "sed failed"
+ # Remove s2n_self_talk_nonblocking_test, it is broken.
+ # See: https://github.com/awslabs/s2n/issues/2051#issuecomment-744543724
+ rm "${S}"/tests/unit/s2n_self_talk_nonblocking_test.c || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=$(usex !static-libs)
+ -DBUILD_TESTING=$(usex test)
+ )
+ cmake_src_configure
+}