summaryrefslogtreecommitdiff
path: root/dev-libs/squareball/squareball-0.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/squareball/squareball-0.2.0.ebuild')
-rw-r--r--dev-libs/squareball/squareball-0.2.0.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/dev-libs/squareball/squareball-0.2.0.ebuild b/dev-libs/squareball/squareball-0.2.0.ebuild
deleted file mode 100644
index ef32270e8cfd..000000000000
--- a/dev-libs/squareball/squareball-0.2.0.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-if [[ ${PV} = *9999* ]]; then
- EGIT_REPO_URI="https://github.com/rafaelmartins/${PN}.git"
- inherit git-r3 autotools
-fi
-
-inherit eutils
-
-DESCRIPTION="A general-purpose library for C99"
-HOMEPAGE="https://github.com/rafaelmartins/squareball"
-
-SRC_URI="https://github.com/rafaelmartins/${PN}/releases/download/v${PV}/${P}.tar.xz"
-KEYWORDS="~amd64 ~x86"
-if [[ ${PV} = *9999* ]]; then
- SRC_URI=""
- KEYWORDS=""
-fi
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="doc test static-libs"
-
-RDEPEND=""
-
-DEPEND="
- virtual/pkgconfig
- test? (
- dev-util/cmocka )
- doc? (
- app-doc/doxygen )"
-
-src_prepare() {
- [[ ${PV} = *9999* ]] && eautoreconf
- default
-}
-
-src_configure() {
- econf \
- $(use_enable doc) \
- $(use_enable test tests) \
- $(use_enable static-libs static) \
- --disable-valgrind
-}
-
-src_compile() {
- default
- use doc && emake docs
-}
-
-src_install() {
- use doc && HTML_DOCS=( doc/build/html/* )
- default
- prune_libtool_files --all
-}