summaryrefslogtreecommitdiff
path: root/dev-libs/volume_key/volume_key-0.3.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/volume_key/volume_key-0.3.9.ebuild')
-rw-r--r--dev-libs/volume_key/volume_key-0.3.9.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-libs/volume_key/volume_key-0.3.9.ebuild b/dev-libs/volume_key/volume_key-0.3.9.ebuild
deleted file mode 100644
index 85b9d8321622..000000000000
--- a/dev-libs/volume_key/volume_key-0.3.9.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{4,5,6} )
-
-inherit autotools python-single-r1
-
-DESCRIPTION="Library for manipulating and storing storage volume encryption keys"
-HOMEPAGE="https://pagure.io/volume_key"
-SRC_URI="http://releases.pagure.org/${PN}/${P}.tar.xz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 ia64 ~mips ppc ppc64 ~sparc x86"
-IUSE="test"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- app-crypt/gpgme
- dev-libs/glib:2
- dev-libs/nspr
- dev-libs/nss
- sys-apps/util-linux
- sys-fs/cryptsetup:=
-"
-DEPEND="
- ${RDEPEND}
- sys-devel/gettext
- test? ( dev-libs/nss[utils] )
- "
-
-RESTRICT="test" # possible gpgme issue
-
-PATCHES=(
- "${FILESDIR}"/${P}-config.h.diff
- "${FILESDIR}"/${PN}-0.3.9-find_python.patch
-
- # Patches from upstream (can usually be removed with next version bump)
- "${FILESDIR}/${P}-cryptsetup2.patch"
-)
-
-pkg_setup() {
- python-single-r1_pkg_setup
-}
-
-src_prepare() {
- default
- eautoreconf
-}