summaryrefslogtreecommitdiff
path: root/dev-libs/xml-security-c
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/xml-security-c')
-rw-r--r--dev-libs/xml-security-c/Manifest5
-rw-r--r--dev-libs/xml-security-c/files/xml-security-c-1.6.1-nss-compilation-fix.patch13
-rw-r--r--dev-libs/xml-security-c/files/xml-security-c-1.7.3-fix-c++14.patch36
-rw-r--r--dev-libs/xml-security-c/metadata.xml14
-rw-r--r--dev-libs/xml-security-c/xml-security-c-1.7.3.ebuild45
5 files changed, 0 insertions, 113 deletions
diff --git a/dev-libs/xml-security-c/Manifest b/dev-libs/xml-security-c/Manifest
deleted file mode 100644
index a28fade6e8fe..000000000000
--- a/dev-libs/xml-security-c/Manifest
+++ /dev/null
@@ -1,5 +0,0 @@
-AUX xml-security-c-1.6.1-nss-compilation-fix.patch 498 BLAKE2B f6469e552ad6cb300556e80c52c881c64123fb34dbce83fe4d77eb2c48de0f20ac4605edc4d2f2712f991b2b55ffdee9f7d91409cbc5dadf7960b2c5c978692a SHA512 cef34103931356f68a250a89f195e4ad0e67a116c6d0de2ab07407f607d70bec0c1e8d57d9eefa47c8bee7f5750668963409a4d740cead239b7ad16665515bb2
-AUX xml-security-c-1.7.3-fix-c++14.patch 1182 BLAKE2B f534183150d2015b42563bd20ba6a39afbad8469d0af6d6746cc36608911e6fa06f8340611760df7e4c3aea8e1ba8d2ef656aaa0712e5453caedca401361fcf9 SHA512 b1a0154b1a973e8ae4f4687c319694b2b6d22dc20385c2e74e27bf00a1887734075da27e10a48d3204d72d35baa55aaba1965984b75512097a0cc38b192211a1
-DIST xml-security-c-1.7.3.tar.gz 909320 BLAKE2B 5fa9f3ae53b93104c191b76f8ae4f9dad69c690d409ae3f13864cf011bbbca740c5378c0718abb496811c9814b5a7f237042af22e697bfa2e5044668ff3fbd2d SHA512 ea46709d6706edf345e19132d9998774e50dc7b5947a7b4a55e3627998f5ac66f976fdff0a5015ef3cee73c03c04f3c4cf993efd397082491c2000c6548b89d2
-EBUILD xml-security-c-1.7.3.ebuild 963 BLAKE2B 7a2ff075d5996cb995df3e3da595adf636ff4b1a92b73c56e2ae6794b0f1de964a2c5d80738bff05daf80f6758c5fe86e104432f7c9de441d8521ad18d63ca9c SHA512 25370e42290a4d3787af196930b106030ec66d5ffef0277bcfe1afa08b8b853ea929a17e021a1c51ca1c69df38c74c0ca1fff17eee75a0a09e0a3c4658136ba1
-MISC metadata.xml 483 BLAKE2B 184149c1f04282005aa8172c19edca6db6ae769d0ea042261180af79734e08554e325a1bf29f01bb27506dc4a3d5161ccb03395cc6f06c929f6d3f43e171643f SHA512 307df4870d40181dfa0fb62b5791a457ae5c1c4b5f752bcfcd3d6224a3f437ebbc17dad8892b8728ef8be152f2a463814404143e0caf92489c6221c1bf216ef2
diff --git a/dev-libs/xml-security-c/files/xml-security-c-1.6.1-nss-compilation-fix.patch b/dev-libs/xml-security-c/files/xml-security-c-1.6.1-nss-compilation-fix.patch
deleted file mode 100644
index 1635d6b80339..000000000000
--- a/dev-libs/xml-security-c/files/xml-security-c-1.6.1-nss-compilation-fix.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/xsec/tools/xtest/xtest.cpp b/xsec/tools/xtest/xtest.cpp
-index ec40cb2..9cd389e 100644
---- a/xsec/tools/xtest/xtest.cpp
-+++ b/xsec/tools/xtest/xtest.cpp
-@@ -2566,7 +2566,7 @@ int main(int argc, char **argv) {
- }
- #endif
- #if defined(XSEC_HAVE_NSS)
-- else if (stricmp(argv[paramCount], "--nss") == 0 || stricmp(argv[paramCount], "-n") == 0) {
-+ else if (_stricmp(argv[paramCount], "--nss") == 0 || _stricmp(argv[paramCount], "-n") == 0) {
- g_useNSS = true;
- paramCount++;
- }
diff --git a/dev-libs/xml-security-c/files/xml-security-c-1.7.3-fix-c++14.patch b/dev-libs/xml-security-c/files/xml-security-c-1.7.3-fix-c++14.patch
deleted file mode 100644
index 40783bf21b29..000000000000
--- a/dev-libs/xml-security-c/files/xml-security-c-1.7.3-fix-c++14.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-Fix building with C++14, which errors out due to bool -> T* conversions
-See also: https://bugs.gentoo.org/show_bug.cgi?id=594234
-
---- a/xsec/enc/OpenSSL/OpenSSLCryptoSymmetricKey.hpp
-+++ b/xsec/enc/OpenSSL/OpenSSLCryptoSymmetricKey.hpp
-@@ -151,7 +151,7 @@
- SymmetricKeyMode mode = MODE_CBC,
- const unsigned char * iv = NULL,
- const unsigned char* tag = NULL,
-- unsigned int taglen = NULL);
-+ unsigned int taglen = 0);
-
- /**
- * \brief Continue an decrypt operation using this key.
---- a/xsec/enc/XSECCryptoSymmetricKey.hpp
-+++ b/xsec/enc/XSECCryptoSymmetricKey.hpp
-@@ -185,7 +185,7 @@
- SymmetricKeyMode mode = MODE_CBC,
- const unsigned char* iv = NULL,
- const unsigned char* tag = NULL,
-- unsigned int taglen = NULL) = 0;
-+ unsigned int taglen = 0) = 0;
-
- /**
- * \brief Continue a decrypt operation using this key.
---- a/xsec/tools/checksig/InteropResolver.cpp
-+++ b/xsec/tools/checksig/InteropResolver.cpp
-@@ -645,7 +645,7 @@
-
- }
-
-- return false;
-+ return NULL;
-
- }
-
diff --git a/dev-libs/xml-security-c/metadata.xml b/dev-libs/xml-security-c/metadata.xml
deleted file mode 100644
index 507ea2f59d11..000000000000
--- a/dev-libs/xml-security-c/metadata.xml
+++ /dev/null
@@ -1,14 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>cpp@gentoo.org</email>
- <name>Gentoo C++ Project</name>
- </maintainer>
- <use>
- <flag name="xalan">Enable support for XSLT and XPath parsing
- by <pkg>dev-libs/xalan-c</pkg></flag>
- <flag name="nss">Use <pkg>dev-libs/nss</pkg> for certain crypto
- operations (configureable at runtime)</flag>
- </use>
-</pkgmetadata>
diff --git a/dev-libs/xml-security-c/xml-security-c-1.7.3.ebuild b/dev-libs/xml-security-c/xml-security-c-1.7.3.ebuild
deleted file mode 100644
index 19b14771f99b..000000000000
--- a/dev-libs/xml-security-c/xml-security-c-1.7.3.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="Apache C++ XML security libraries"
-HOMEPAGE="http://santuario.apache.org/"
-SRC_URI="mirror://apache/santuario/c-library/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="debug examples libressl nss static-libs xalan"
-
-RDEPEND=">=dev-libs/xerces-c-3.1
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- nss? ( dev-libs/nss )
- xalan? ( dev-libs/xalan-c )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-DOCS=( CHANGELOG.txt NOTICE.txt )
-PATCHES=(
- "${FILESDIR}/${PN}-1.6.1-nss-compilation-fix.patch"
- "${FILESDIR}/${PN}-1.7.3-fix-c++14.patch"
-)
-
-src_configure() {
- econf \
- --with-openssl \
- $(use_enable static-libs static) \
- $(use_enable debug) \
- $(use_with xalan) \
- $(use_with nss)
-}
-
-src_install() {
- default
- if use examples ; then
- docinto examples
- dodoc xsec/samples/*.cpp
- fi
-}