summaryrefslogtreecommitdiff
path: root/dev-libs/xxhash/xxhash-0.7.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/xxhash/xxhash-0.7.3.ebuild')
-rw-r--r--dev-libs/xxhash/xxhash-0.7.3.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-libs/xxhash/xxhash-0.7.3.ebuild b/dev-libs/xxhash/xxhash-0.7.3.ebuild
deleted file mode 100644
index fbebd117c825..000000000000
--- a/dev-libs/xxhash/xxhash-0.7.3.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-DESCRIPTION="Extremely fast non-cryptographic hash algorithm"
-HOMEPAGE="http://www.xxhash.net"
-SRC_URI="https://github.com/Cyan4973/xxHash/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD-2 GPL-2+"
-# https://abi-laboratory.pro/tracker/timeline/xxhash
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-IUSE="static-libs"
-
-S="${WORKDIR}/xxHash-${PV}"
-
-src_compile() {
- PREFIX="${EPREFIX}/usr" \
- LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
- emake AR="$(tc-getAR)" CC="$(tc-getCC)"
-}
-
-src_install() {
- PREFIX="${EPREFIX}/usr" \
- LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
- MANDIR="${EPREFIX}/usr/share/man/man1" \
- emake DESTDIR="${D}" install
-
- if ! use static-libs ; then
- rm "${ED}"/usr/$(get_libdir)/libxxhash.a || die
- fi
-}