summaryrefslogtreecommitdiff
path: root/dev-lua/lpeg/lpeg-0.12.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lua/lpeg/lpeg-0.12.ebuild')
-rw-r--r--dev-lua/lpeg/lpeg-0.12.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-lua/lpeg/lpeg-0.12.ebuild b/dev-lua/lpeg/lpeg-0.12.ebuild
deleted file mode 100644
index effaef3753fd..000000000000
--- a/dev-lua/lpeg/lpeg-0.12.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit flag-o-matic toolchain-funcs eutils multilib
-
-DESCRIPTION="Parsing Expression Grammars for Lua"
-HOMEPAGE="http://www.inf.puc-rio.br/~roberto/lpeg/"
-SRC_URI="http://www.inf.puc-rio.br/~roberto/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm hppa ~mips x86"
-IUSE="debug doc"
-
-RDEPEND=">=dev-lang/lua-5.1"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-makefile.patch
- use debug && append-cflags -DLPEG_DEBUG
-}
-
-src_compile() {
- emake CC="$(tc-getCC)"
-}
-
-src_test() {
- lua test.lua || die
-}
-
-src_install() {
- exeinto "$($(tc-getPKG_CONFIG) --variable INSTALL_CMOD lua)"
- doexe lpeg.so
-
- dodoc HISTORY
-
- use doc && dohtml *
-}