summaryrefslogtreecommitdiff
path: root/dev-lua/luv/files/luv-1.32.0.0-cmake_lua_version.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lua/luv/files/luv-1.32.0.0-cmake_lua_version.patch')
-rw-r--r--dev-lua/luv/files/luv-1.32.0.0-cmake_lua_version.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/dev-lua/luv/files/luv-1.32.0.0-cmake_lua_version.patch b/dev-lua/luv/files/luv-1.32.0.0-cmake_lua_version.patch
new file mode 100644
index 000000000000..84af757d248b
--- /dev/null
+++ b/dev-lua/luv/files/luv-1.32.0.0-cmake_lua_version.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -107,7 +107,7 @@
+ include_directories(${LUAJIT_INCLUDE_DIR})
+ link_directories(${LUAJIT_LIBRARIES})
+ else (USE_LUAJIT)
+- find_package(Lua REQUIRED)
++ find_package(Lua ${LUA_VERSION} EXACT REQUIRED)
+ include_directories(${LUA_INCLUDE_DIR})
+ endif (USE_LUAJIT)
+