summaryrefslogtreecommitdiff
path: root/dev-ml/0install
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/0install')
-rw-r--r--dev-ml/0install/0install-2.18.ebuild33
-rw-r--r--dev-ml/0install/Manifest3
-rw-r--r--dev-ml/0install/metadata.xml19
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-ml/0install/0install-2.18.ebuild b/dev-ml/0install/0install-2.18.ebuild
new file mode 100644
index 000000000000..b88424ef2d7c
--- /dev/null
+++ b/dev-ml/0install/0install-2.18.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Package dependency solver"
+HOMEPAGE="https://docs.0install.net/developers/solver/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tbz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="+ocamlopt"
+
+RDEPEND="
+ dev-ml/lwt:=[ocamlopt?]
+ dev-ml/ocurl:=[ocamlopt?]
+ dev-ml/yojson:=[ocamlopt?]
+ dev-ml/xmlm:=
+"
+
+RESTRICT="test"
+
+src_compile() {
+ dune-compile 0install-solver 0install
+}
+
+src_install() {
+ dune-install 0install-solver 0install
+}
diff --git a/dev-ml/0install/Manifest b/dev-ml/0install/Manifest
new file mode 100644
index 000000000000..925098c71aff
--- /dev/null
+++ b/dev-ml/0install/Manifest
@@ -0,0 +1,3 @@
+DIST 0install-2.18.tbz 452385 BLAKE2B 90b4ce4d508005fd3fc9303e4fbb86fe830568fccab2aa6cbbadd16b232b3b3d2446dcd830069e0d96011c500f2e484d7009fbeedf12b6f520e17042aa784605 SHA512 6d4734754951fad9caad5d876a1301e283bdd77a080d6601d57b21c540a30a616b18f664cbd4f86748c90de41cf3ef54f3a883fd75f638abbe3630a0320e4a7f
+EBUILD 0install-2.18.ebuild 600 BLAKE2B 81a38f3bdb85606de4b62fc7c3f955995c29fc37fb757c3f696b7aa3b0995a33a64be1f84ac4555d93bf5f65d1502dfe6e3570d284b5ea34b0ecac9eb11af6f7 SHA512 ee2e2f9910d3d06e8cb205119f97d16db52e7ef498943888dc939011a64ae8abcaf533effe2ff828644f0cb18a6f12a93526ef162bc2e19e4bb7e1a5d159e783
+MISC metadata.xml 737 BLAKE2B 53ffbf43909744e16b98265d7742a95e7274ddb32741cc5ba055e1e7891fc77f377b758706d0fc08fa64aaa865dddf9de643556289db1cfcfca483b4e7d834cb SHA512 8a49e83b132b41803bc13c02d77ccdfaa422eef6a4a918502b1cfbb9d58e5b02e9887d06555e43169c776012bd2b4654860f724f451fb2d57ddd5d6e2ae43f37
diff --git a/dev-ml/0install/metadata.xml b/dev-ml/0install/metadata.xml
new file mode 100644
index 000000000000..cb019eed3ab9
--- /dev/null
+++ b/dev-ml/0install/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <longdescription lang="en">
+ Zero Install is a decentralised cross-distribution software
+ installation system. Other features include full support for shared
+ libraries (with a SAT solver for dependency resolution),
+ sharing between users, and integration with native platform package
+ managers. It supports both binary and source packages, and works on
+ Linux, macOS, Unix and Windows systems.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">0install/0install</remote-id>
+ </upstream>
+</pkgmetadata>