summaryrefslogtreecommitdiff
path: root/dev-ml/calendar/calendar-2.04-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/calendar/calendar-2.04-r1.ebuild')
-rw-r--r--dev-ml/calendar/calendar-2.04-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ml/calendar/calendar-2.04-r1.ebuild b/dev-ml/calendar/calendar-2.04-r1.ebuild
new file mode 100644
index 000000000000..ee9f5e211003
--- /dev/null
+++ b/dev-ml/calendar/calendar-2.04-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib
+
+DESCRIPTION="Ocaml library to handle dates and time"
+HOMEPAGE="https://forge.ocamlcore.org/projects/calendar/"
+SRC_URI="https://download.ocamlcore.org/${PN}/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+DEPEND="<dev-lang/ocaml-5:=[ocamlopt]"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake
+ use doc && emake doc
+}
+
+src_test() {
+ emake tests
+}
+
+src_install() {
+ findlib_src_install
+ dodoc README CHANGES
+
+ if use doc ; then
+ docinto html
+ dodoc -r doc
+ fi
+}