summaryrefslogtreecommitdiff
path: root/dev-ml/cstruct
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/cstruct')
-rw-r--r--dev-ml/cstruct/Manifest3
-rw-r--r--dev-ml/cstruct/cstruct-6.2.0.ebuild19
-rw-r--r--dev-ml/cstruct/metadata.xml11
3 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/cstruct/Manifest b/dev-ml/cstruct/Manifest
new file mode 100644
index 000000000000..7a3f12bd47d1
--- /dev/null
+++ b/dev-ml/cstruct/Manifest
@@ -0,0 +1,3 @@
+DIST cstruct-6.2.0.tbz 241841 BLAKE2B 9a662bf1208e80afda486dd46169b281e838e49666aca01a9ad57b9516fa055af315ea12d5e5bb8994df67eb2f6edabe544a89a2a2a370249e5b72e109f01b1a SHA512 8d33fe6b3707a3994d0225cd33cadde0bb2ca834ef01096e3df33a08e4a8c6d02ebccddf558a73988b8a5595b65fdc10de61efbf872c6c9e55c719c7e19c463d
+EBUILD cstruct-6.2.0.ebuild 439 BLAKE2B ce08122a53d6953199d3f07762a7604712c226d03c608656da03e62d7e08d37564041e35ded5a9a622319b10f18c613e8db02423b0256dd8eac3762fc3e45a18 SHA512 dcdf472e7b9be12d6e57d726695b218362ef8e9e7d868e028916375c9cdb3a1736fe9b241d1185dab46046bc778d1756756319c2741c3b8494840a4197ac8d60
+MISC metadata.xml 318 BLAKE2B 764566780536ed76d1e9a529d0a38ddf28638ed336359216d5bf081d97355018d7646dbcf2e04925230aef3ea5928303d05ff66cffb64395ec9328e1f93ed22f SHA512 892ae500837814075e3e83de8ead57eecd1348c4bbb48671086714b36c11c4db0edd9fb56f31a6da87048a640336413b326a8e830f6c918125a500635c05d4c5
diff --git a/dev-ml/cstruct/cstruct-6.2.0.ebuild b/dev-ml/cstruct/cstruct-6.2.0.ebuild
new file mode 100644
index 000000000000..6d78859ac5fc
--- /dev/null
+++ b/dev-ml/cstruct/cstruct-6.2.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Access C-like structures directly from OCaml"
+HOMEPAGE="https://github.com/mirage/ocaml-cstruct"
+SRC_URI="https://github.com/mirage/ocaml-cstruct/releases/download/v${PV}/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64"
+IUSE="+ocamlopt"
+
+src_compile() {
+ dune-compile ${PN}
+}
diff --git a/dev-ml/cstruct/metadata.xml b/dev-ml/cstruct/metadata.xml
new file mode 100644
index 000000000000..ed977f2b227a
--- /dev/null
+++ b/dev-ml/cstruct/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mirage/ocaml-cstruct</remote-id>
+ </upstream>
+</pkgmetadata>