summaryrefslogtreecommitdiff
path: root/dev-ml/csv/csv-1.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/csv/csv-1.6.ebuild')
-rw-r--r--dev-ml/csv/csv-1.6.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ml/csv/csv-1.6.ebuild b/dev-ml/csv/csv-1.6.ebuild
new file mode 100644
index 000000000000..1d0efd903991
--- /dev/null
+++ b/dev-ml/csv/csv-1.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="A pure OCaml library to read and write CSV files"
+HOMEPAGE="https://github.com/Chris00/ocaml-csv"
+SRC_URI="https://github.com/Chris00/ocaml-csv/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+lwt"
+
+DEPEND="lwt? ( dev-ml/lwt:= )"
+RDEPEND="${DEPEND}"
+
+DOCS=( "README.txt" "AUTHORS.txt" )
+
+src_configure() {
+ oasis_configure_opts="$(use_enable lwt)" \
+ oasis_src_configure
+}