summaryrefslogtreecommitdiff
path: root/dev-ml/extlib
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/extlib')
-rw-r--r--dev-ml/extlib/Manifest6
-rw-r--r--dev-ml/extlib/extlib-1.7.1.ebuild51
-rw-r--r--dev-ml/extlib/extlib-1.7.2.ebuild47
-rw-r--r--dev-ml/extlib/files/ocaml405.patch35
-rw-r--r--dev-ml/extlib/metadata.xml12
5 files changed, 151 insertions, 0 deletions
diff --git a/dev-ml/extlib/Manifest b/dev-ml/extlib/Manifest
new file mode 100644
index 000000000000..cbc97d4796a1
--- /dev/null
+++ b/dev-ml/extlib/Manifest
@@ -0,0 +1,6 @@
+AUX ocaml405.patch 1539 BLAKE2B d61c8398986a66664810684870351856ca94318a82d07194908c570aefc9b2b3196b95f651717b058e95b853e1862c3a27218afa71a809f766b908cde3e9cece SHA512 664c9b840b77d08095e03dbd398f6af3118237fbffe73499bc2b0ee0dc8e40311337e65f3e0e95b2f87dddb9e75b18d27d2b712b314f725d97fd537f2ca23e52
+DIST extlib-1.7.1.tar.gz 85397 BLAKE2B f2e924f651cc43ca29914c95400a26bfd062ecb4e7379d169533d394497215906b56e8f57ba29358965f0b8c125c33dcb9a0a95c09488404fd348261d075457f SHA512 42ea1be22a57ab31e5857df0c4c0f98a07e1b5958b34181cd5ab7c83ded112c208315d22cd3dd178d53e75ca109a70cb47ae479e95be8c47ea2087b1a158dc4d
+DIST extlib-1.7.2.tar.gz 85934 BLAKE2B fab7f5f99be414a83f46144bc8f2f54aeb545ef9041b62f227f9dafd267a3f8608b94388ffc39903b069ec7d481b4da8a6a2e9aa289c68263613cf64aa6a45e0 SHA512 d9f34f5bbd5e94a8dccc5bdbc1ec0e5015608675469c4f513461fa587a5eb7e1398542388fd885d7656591ca85ce30c0e2a9ee26b9722a9dd65189aac35d64ed
+EBUILD extlib-1.7.1.ebuild 891 BLAKE2B d6f027a141b65333b975fe0b07a2f91d93568f888e8d9d3c7017c372abf716458ba85e48be93b270a000579ac2413f10ed56be9b8a72b7a346d05f69f8118f05 SHA512 b349d8d19e5f8a4ea4370ea9301f44e292a28dcbe8426e3d068042e22c5d643c161c5b4131ce1ed66de155a681c9c99068dccbb569d710e8c0ffb1ef36ce0cba
+EBUILD extlib-1.7.2.ebuild 840 BLAKE2B 86d4c868a5a7a24a47849746b70ea15f21a8d69fb9b7ec82ae87217ccac760a04de02317132729ee0bdaa9ed8ad42ef0a11a1bb735afb82ae76cad11cc21c7b4 SHA512 c50cf98e44d44fe48f0c67ed398811cca2cbc0b2d94edf474c2d7d5bed5918263cb562df305b8aa31d501dc6e97417bc7acd4231e31bcefb7463b09161617211
+MISC metadata.xml 387 BLAKE2B f69d20e297ba1bf4de102818f365e5a4a6b51373aeefbf891d1449edd959562a9575f3764f01dc70d5f4fb1f50f3bf04b389d32dfd1bbf0e88142077f15ef39e SHA512 b2805065022f5449f11da6db984ad7ea09260a600e0ac44228944f70fbede3de0cd3637c4fef6f0d33c16cd974fbd43c90b7a0fd7177a8ad9667d7a3464d1484
diff --git a/dev-ml/extlib/extlib-1.7.1.ebuild b/dev-ml/extlib/extlib-1.7.1.ebuild
new file mode 100644
index 000000000000..33dffa043aaf
--- /dev/null
+++ b/dev-ml/extlib/extlib-1.7.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="Standard library extensions for O'Caml"
+HOMEPAGE="https://github.com/ygrek/ocaml-extlib"
+SRC_URI="https://github.com/ygrek/ocaml-extlib/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="LGPL-2.1"
+DEPEND="
+ >=dev-lang/ocaml-3.10.2:=[ocamlopt?]
+ dev-ml/cppo:=
+"
+RDEPEND="${DEPEND}"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~arm ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc +ocamlopt"
+S="${WORKDIR}/ocaml-${P}"
+
+src_prepare() {
+ epatch "${FILESDIR}/ocaml405.patch"
+}
+
+src_compile() {
+ cd src
+ emake -j1 all
+ if use ocamlopt; then
+ emake opt cmxs
+ fi
+
+ if use doc; then
+ emake doc
+ fi
+}
+
+src_test() {
+ emake -j1 test
+}
+
+src_install () {
+ findlib_src_install
+
+ # install documentation
+ dodoc README.md
+
+ if use doc; then
+ dohtml src/doc/*
+ fi
+}
diff --git a/dev-ml/extlib/extlib-1.7.2.ebuild b/dev-ml/extlib/extlib-1.7.2.ebuild
new file mode 100644
index 000000000000..4f53ed7d6c4a
--- /dev/null
+++ b/dev-ml/extlib/extlib-1.7.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="Standard library extensions for O'Caml"
+HOMEPAGE="https://github.com/ygrek/ocaml-extlib"
+SRC_URI="https://github.com/ygrek/ocaml-extlib/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="LGPL-2.1"
+DEPEND="
+ >=dev-lang/ocaml-3.10.2:=[ocamlopt?]
+ dev-ml/cppo:=
+"
+RDEPEND="${DEPEND}"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc +ocamlopt"
+S="${WORKDIR}/ocaml-${P}"
+
+src_compile() {
+ cd src
+ emake -j1 all
+ if use ocamlopt; then
+ emake opt cmxs
+ fi
+
+ if use doc; then
+ emake doc
+ fi
+}
+
+src_test() {
+ emake -j1 test
+}
+
+src_install () {
+ findlib_src_install
+
+ # install documentation
+ dodoc README.md
+
+ if use doc; then
+ dohtml src/doc/*
+ fi
+}
diff --git a/dev-ml/extlib/files/ocaml405.patch b/dev-ml/extlib/files/ocaml405.patch
new file mode 100644
index 000000000000..4e3b04a1c8e5
--- /dev/null
+++ b/dev-ml/extlib/files/ocaml405.patch
@@ -0,0 +1,35 @@
+Index: ocaml-extlib-1.7.1/src/configure.ml
+===================================================================
+--- ocaml-extlib-1.7.1.orig/src/configure.ml
++++ ocaml-extlib-1.7.1/src/configure.ml
+@@ -3,5 +3,6 @@ let () =
+ print_endline (if Sys.ocaml_version >= "4.02.0" then "-D OCAML4_02 " else "");
+ print_endline (if Sys.ocaml_version >= "4.03.0" then "-D OCAML4_03 " else "");
+ print_endline (if Sys.ocaml_version >= "4.04.0" then "-D OCAML4_04 " else "");
++ print_endline (if Sys.ocaml_version >= "4.05.0" then "-D OCAML4_05 " else "");
+ let (_:int) = Sys.command "ocamlfind query -format \"-D WITH_BYTES\" bytes" in ();
+ exit 0
+Index: ocaml-extlib-1.7.1/src/extHashtbl.mli
+===================================================================
+--- ocaml-extlib-1.7.1.orig/src/extHashtbl.mli
++++ ocaml-extlib-1.7.1/src/extHashtbl.mli
+@@ -132,6 +132,9 @@ module type S =
+ val add : 'a t -> key -> 'a -> unit
+ val remove : 'a t -> key -> unit
+ val find : 'a t -> key -> 'a
++#ifdef OCAML4_05
++ val find_opt: 'a t -> key -> 'a option
++#endif
+ val find_all : 'a t -> key -> 'a list
+ val replace : 'a t -> key -> 'a -> unit
+ val mem : 'a t -> key -> bool
+@@ -167,6 +170,9 @@ module type SeededS =
+ val add : 'a t -> key -> 'a -> unit
+ val remove : 'a t -> key -> unit
+ val find : 'a t -> key -> 'a
++#ifdef OCAML4_05
++ val find_opt : 'a t -> key -> 'a option
++#endif
+ val find_all : 'a t -> key -> 'a list
+ val replace : 'a t -> key -> 'a -> unit
+ val mem : 'a t -> key -> bool
diff --git a/dev-ml/extlib/metadata.xml b/dev-ml/extlib/metadata.xml
new file mode 100644
index 000000000000..69a0f75ce938
--- /dev/null
+++ b/dev-ml/extlib/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">ocaml-extlib</remote-id>
+ <remote-id type="github">ygrek/ocaml-extlib</remote-id>
+ </upstream>
+</pkgmetadata>