summaryrefslogtreecommitdiff
path: root/dev-ml/fieldslib/fieldslib-0.9.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/fieldslib/fieldslib-0.9.0.ebuild')
-rw-r--r--dev-ml/fieldslib/fieldslib-0.9.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ml/fieldslib/fieldslib-0.9.0.ebuild b/dev-ml/fieldslib/fieldslib-0.9.0.ebuild
new file mode 100644
index 000000000000..9f1092e48f00
--- /dev/null
+++ b/dev-ml/fieldslib/fieldslib-0.9.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Folding over record fields"
+HOMEPAGE="https://github.com/janestreet/fieldslib"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-lang/ocaml:=
+ dev-ml/base:=
+ dev-ml/ppx_driver:=
+ dev-ml/ocaml-migrate-parsetree:=
+"
+DEPEND="${RDEPEND} dev-ml/opam dev-ml/jbuilder"
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+}