summaryrefslogtreecommitdiff
path: root/dev-ml/findlib/findlib-1.9.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/findlib/findlib-1.9.5.ebuild')
-rw-r--r--dev-ml/findlib/findlib-1.9.5.ebuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/dev-ml/findlib/findlib-1.9.5.ebuild b/dev-ml/findlib/findlib-1.9.5.ebuild
index 6d9c0f236c54..c25719598182 100644
--- a/dev-ml/findlib/findlib-1.9.5.ebuild
+++ b/dev-ml/findlib/findlib-1.9.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -52,21 +52,22 @@ src_install() {
docinto html
dodoc -r ref-html guide-html
fi
+
+ # See bug #803275 and bug #833604
+ rm -f "${ED}"/usr/$(get_libdir)/ocaml/{ocamlbuild,labltk}/META || die
}
check_stublibs() {
- local ocaml_stdlib=`ocamlc -where`
+ local ocaml_stdlib=$(ocamlc -where)
local ldconf="${ocaml_stdlib}/ld.conf"
- if [ ! -e ${ldconf} ]
- then
- echo "${ocaml_stdlib}" > ${ldconf}
- echo "${ocaml_stdlib}/stublibs" >> ${ldconf}
+ if [[ ! -e ${ldconf} ]] ; then
+ echo "${ocaml_stdlib}" > ${ldconf} || die
+ echo "${ocaml_stdlib}/stublibs" >> ${ldconf} || die
fi
- if [ -z `grep -e ${stublibs} ${ldconf}` ]
- then
- echo ${stublibs} >> ${ldconf}
+ if ! grep -qe ${stublibs} ${ldconf} ; then
+ echo ${stublibs} >> ${ldconf} || die
fi
}