summaryrefslogtreecommitdiff
path: root/dev-ml/fmt/fmt-0.8.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/fmt/fmt-0.8.4.ebuild')
-rw-r--r--dev-ml/fmt/fmt-0.8.4.ebuild32
1 files changed, 0 insertions, 32 deletions
diff --git a/dev-ml/fmt/fmt-0.8.4.ebuild b/dev-ml/fmt/fmt-0.8.4.ebuild
deleted file mode 100644
index 19b27b4284d0..000000000000
--- a/dev-ml/fmt/fmt-0.8.4.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit findlib opam
-
-DESCRIPTION="Combinators to devise OCaml Format pretty-printing functions"
-HOMEPAGE="http://erratique.ch/software/fmt https://github.com/dbuenzli/fmt"
-SRC_URI="http://erratique.ch/software/fmt/releases/${P}.tbz"
-
-LICENSE="ISC"
-SLOT="0/${PV}"
-KEYWORDS="~amd64"
-IUSE="test"
-
-RDEPEND="dev-ml/result:=[ocamlopt]
- dev-lang/ocaml:=[ocamlopt]
- dev-ml/uchar:=[ocamlopt]
- dev-ml/cmdliner:=[ocamlopt]"
-DEPEND="${RDEPEND}
- >=dev-ml/topkg-0.9
- dev-ml/ocamlbuild
- dev-ml/findlib"
-
-src_compile() {
- ocaml pkg/pkg.ml build --tests $(usex test 'true' 'false') || die
-}
-
-src_test() {
- ocaml pkg/pkg.ml test || die
-}