summaryrefslogtreecommitdiff
path: root/dev-ml/gsl-ocaml
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/gsl-ocaml')
-rw-r--r--dev-ml/gsl-ocaml/Manifest4
-rw-r--r--dev-ml/gsl-ocaml/gsl-ocaml-1.19.1.ebuild29
-rw-r--r--dev-ml/gsl-ocaml/gsl-ocaml-1.24.3.ebuild27
3 files changed, 29 insertions, 31 deletions
diff --git a/dev-ml/gsl-ocaml/Manifest b/dev-ml/gsl-ocaml/Manifest
index 09276ad20f09..4c37c25073ef 100644
--- a/dev-ml/gsl-ocaml/Manifest
+++ b/dev-ml/gsl-ocaml/Manifest
@@ -1,3 +1,3 @@
-DIST gsl-ocaml-1.19.1.tar.gz 167549 BLAKE2B 17d559b31a2be9583fd616b273f1d5cac5a42bebc7df2cf4882ba5bf7ddf411971b4f49dc36eb3bcdb0265ea204d0ea0ba19bc6c63f49a6b8b6075715bd0a967 SHA512 be199d46479f07a16d2f667d7a29675171bc4ecc5a6e5948335bf98f72e6f12474d16455a22e6bfc73683f1d67de3a186d75f817f398f6621241b640c333e07d
-EBUILD gsl-ocaml-1.19.1.ebuild 654 BLAKE2B 24ca5f842efc365231d480097d212f32d023e7f35f7451ef2c6457ecf115c350b2710123b50264436c280648ea51800d60f26fbc388b6f9fd8cbfd87e94a7c88 SHA512 35e36e20006bfc00f63f4f0dfa5acf16b0f6deea6fd585d9ae7c49dee961de5614d4c56cffe3867f06ffa4261c26a49f628b1d6f78c5cc8a06b127e027c1ac92
+DIST gsl-1.24.3.tbz 100642 BLAKE2B cf1bd63593901ba41ec33a8d073d923351e8cd6021f0402ce337242dd6b378408e740f2904a1c53f123453444dc08a05971921ab53e683b2ecf1e8a869f28e46 SHA512 c6e2578618591d1bef428693b69026cdea0f1606cd25d9f02d637a90256a5685eee70ecd0259d2595a1cd7b292c34e3c913c007e2706aa125af045d37e55d9c4
+EBUILD gsl-ocaml-1.24.3.ebuild 607 BLAKE2B 06adeef9509bce72e4c07be5ca929a8d39ced66a3626ca113f72178b7b91d522e9b5723b38e358454577565b5fb687a9aaad3dd5ec3bd1d7f08660de1400f881 SHA512 9b673f03b2e73cdde6eed613f8f99c719fea9e27fc9cc7ab4515f4285b475e15519d18b93e2a7cef6f0ed88c402727a7f8da522c8a51e6dca9393bbf9bfe1068
MISC metadata.xml 405 BLAKE2B 9456c1d7c9bfc2e658ca7aa43f4009ec24bca515d3a4de2d66d47399128b10abf165f9012bd7629356fc7e1c998c77c7ee9e4e2ad6da8d49f66383f3d5e21222 SHA512 56eaeacab9b94d6df7372c027c8e139e3fdb8763f3a67342da7f460a48ac2f944fee48721a441e26b2f74254d2af0b3ded55da015bcc7bbf43cc5e9dc1314443
diff --git a/dev-ml/gsl-ocaml/gsl-ocaml-1.19.1.ebuild b/dev-ml/gsl-ocaml/gsl-ocaml-1.19.1.ebuild
deleted file mode 100644
index 7b461efb3ec0..000000000000
--- a/dev-ml/gsl-ocaml/gsl-ocaml-1.19.1.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-OASIS_BUILD_DOCS=1
-OASIS_BUILD_TESTS=1
-
-inherit oasis
-
-DESCRIPTION="OCaml bindings for the GSL library (successor of dev-ml/ocamlgsl)"
-HOMEPAGE="https://github.com/mmottl/gsl-ocaml"
-SRC_URI="https://github.com/mmottl/${PN}/releases/download/v${PV}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-DEPEND=">=sci-libs/gsl-1.19"
-RDEPEND="${DEPEND}
- !dev-ml/ocamlgsl"
-
-DOCS=( CHANGES.txt README.md NOTES.md TODO.md )
-
-src_prepare() {
- oasis_configure_opts="$(use_enable examples)"
-}
diff --git a/dev-ml/gsl-ocaml/gsl-ocaml-1.24.3.ebuild b/dev-ml/gsl-ocaml/gsl-ocaml-1.24.3.ebuild
new file mode 100644
index 000000000000..7de5ef50474e
--- /dev/null
+++ b/dev-ml/gsl-ocaml/gsl-ocaml-1.24.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DUNE_PKG_NAME="gsl"
+inherit dune
+
+MY_P=${P/-ocaml/}
+DESCRIPTION="OCaml bindings for the GSL library (successor of dev-ml/ocamlgsl)"
+HOMEPAGE="https://github.com/mmottl/gsl-ocaml"
+SRC_URI="https://github.com/mmottl/${PN}/releases/download/${PV}/${MY_P}.tbz"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ dev-ml/dune-configurator
+ >=sci-libs/gsl-1.19
+"
+RDEPEND="${DEPEND}
+ !dev-ml/ocamlgsl"
+
+# DOCS=( CHANGES.txt README.md NOTES.md TODO.md )