summaryrefslogtreecommitdiff
path: root/dev-ml/jsonm/jsonm-1.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/jsonm/jsonm-1.0.1.ebuild')
-rw-r--r--dev-ml/jsonm/jsonm-1.0.1.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-ml/jsonm/jsonm-1.0.1.ebuild b/dev-ml/jsonm/jsonm-1.0.1.ebuild
index a51e2c2f0762..07992359e9a5 100644
--- a/dev-ml/jsonm/jsonm-1.0.1.ebuild
+++ b/dev-ml/jsonm/jsonm-1.0.1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=7
inherit findlib
@@ -31,8 +31,10 @@ src_compile() {
src_install() {
# Can't use opam-installer here as it is an opam dep...
findlib_src_preinst
+
local nativelibs="$(echo _build/src/${PN}.cm{x,xa,xs,ti} _build/src/${PN}.a)"
ocamlfind install ${PN} _build/pkg/META _build/src/${PN}.mli _build/src/${PN}.cm{a,i} ${nativelibs} || die
+
newbin _build/test/jsontrip.native jsontrip
dodoc CHANGES.md TODO.md README.md
}