summaryrefslogtreecommitdiff
path: root/dev-ml/mirage-clock/mirage-clock-4.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/mirage-clock/mirage-clock-4.2.0.ebuild')
-rw-r--r--dev-ml/mirage-clock/mirage-clock-4.2.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ml/mirage-clock/mirage-clock-4.2.0.ebuild b/dev-ml/mirage-clock/mirage-clock-4.2.0.ebuild
new file mode 100644
index 000000000000..5e66c4963037
--- /dev/null
+++ b/dev-ml/mirage-clock/mirage-clock-4.2.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Portable clock implementation for Unix and Xen"
+HOMEPAGE="https://github.com/mirage/mirage-clock"
+SRC_URI="https://github.com/mirage/mirage-clock/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+BDEPEND="dev-ml/dune-configurator"
+
+src_install() {
+ dune-install mirage-clock mirage-clock-solo5 mirage-clock-unix
+}