summaryrefslogtreecommitdiff
path: root/dev-ml/mtime/mtime-1.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/mtime/mtime-1.1.0.ebuild')
-rw-r--r--dev-ml/mtime/mtime-1.1.0.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/dev-ml/mtime/mtime-1.1.0.ebuild b/dev-ml/mtime/mtime-1.1.0.ebuild
deleted file mode 100644
index 1c5185f3abd3..000000000000
--- a/dev-ml/mtime/mtime-1.1.0.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit eutils opam
-
-DESCRIPTION="OCaml module to access monotonic wall-clock time"
-HOMEPAGE="http://erratique.ch/software/mtime https://github.com/dbuenzli/mtime"
-SRC_URI="http://erratique.ch/software/mtime/releases/${P}.tbz"
-
-LICENSE="ISC"
-SLOT="0/${PV}"
-KEYWORDS="~amd64"
-IUSE="javascript test"
-
-RDEPEND="dev-lang/ocaml:=[ocamlopt]
- javascript? ( dev-ml/js_of_ocaml:= )
-"
-DEPEND="${RDEPEND}
- dev-ml/topkg
- dev-ml/ocamlbuild
- dev-ml/findlib"
-
-src_compile() {
- ocaml pkg/pkg.ml build \
- --with-js_of_ocaml $(usex javascript true false) \
- --tests $(usex test true false) \
- || die
-}
-
-src_test() {
- ocaml pkg/pkg.ml test || die
-}