summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-gettext-stub
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocaml-gettext-stub')
-rw-r--r--dev-ml/ocaml-gettext-stub/Manifest3
-rw-r--r--dev-ml/ocaml-gettext-stub/metadata.xml21
-rw-r--r--dev-ml/ocaml-gettext-stub/ocaml-gettext-stub-0.4.2.ebuild37
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-ml/ocaml-gettext-stub/Manifest b/dev-ml/ocaml-gettext-stub/Manifest
new file mode 100644
index 000000000000..fbc975bfc0e4
--- /dev/null
+++ b/dev-ml/ocaml-gettext-stub/Manifest
@@ -0,0 +1,3 @@
+DIST ocaml-gettext-0.4.2.tar.gz 110249 BLAKE2B 54a25ba9f8fb20194fdfaf651586222fab68f927ebfa711812f7c9a387ff40c19e1bf3f63124127356b32b0ca0be2c5ff4e1cdfaf5f3afe690b90c0ca96c470d SHA512 fb89be8d8d9e0ed9327b81a0c81c884ff3f1a97e46b475ef8084abded5c84a256de05d5aa0f42be94f43ab438276a4506af726b6950e4161359a9616fb5832ec
+EBUILD ocaml-gettext-stub-0.4.2.ebuild 848 BLAKE2B 83bb6bb6de2f3965bac79c0a759fcb23821c9d936c9793a65ff25e96b057104edd6396878083a5cc0cff80516f51f7d348a1fc9aa01f35d211a6aefd5b423747 SHA512 26127ddbbbda6cae9af889d6026915a64f80cf89ffe1e8913dbc463534b3b8ba0ed2c94630afff1dbda7deb7e1886eb46dddad263d39031fe3ff54f9d9194e27
+MISC metadata.xml 632 BLAKE2B d683f2b55fe66ac0ccae90494f7485042652afc9a1c01d583cef1fb9181b15d9a9d66c44eee51fb380318946288e9a05320896f376cc91992115349987ec8466 SHA512 70332af42127e51035802cf05ed4fff1d2ca363ecfe7c43a6db70277e6625de026091f2fc0b98158c283f7e3d9107d898708443121d935f6618ed0d822883610
diff --git a/dev-ml/ocaml-gettext-stub/metadata.xml b/dev-ml/ocaml-gettext-stub/metadata.xml
new file mode 100644
index 000000000000..4014d3ca4a80
--- /dev/null
+++ b/dev-ml/ocaml-gettext-stub/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>rkitover@gmail.com</email>
+ <name>Rafael Kitover</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">gildor478/ocaml-gettext</remote-id>
+ </upstream>
+ <use>
+ <flag name="ocamlopt">
+ Whether the OCaml native code compiler is used. Must be set globally and
+ match dev-lang/ocaml.
+ </flag>
+ </use>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-gettext-stub/ocaml-gettext-stub-0.4.2.ebuild b/dev-ml/ocaml-gettext-stub/ocaml-gettext-stub-0.4.2.ebuild
new file mode 100644
index 000000000000..b44afdf69321
--- /dev/null
+++ b/dev-ml/ocaml-gettext-stub/ocaml-gettext-stub-0.4.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN=${PN/-stub/}
+MY_P=${P/-stub/}
+DUNE_PKG_NAME="gettext-stub"
+inherit dune
+
+DESCRIPTION="Support for internationalization of OCaml programs using native gettext library"
+HOMEPAGE="https://github.com/gildor478/ocaml-gettext"
+SRC_URI="https://github.com/gildor478/ocaml-gettext/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ >=dev-ml/cppo-1.6.6
+ dev-ml/dune-configurator
+"
+RDEPEND="
+ dev-ml/base:=[ocamlopt=]
+ dev-ml/camomile:=[ocamlopt=]
+ dev-ml/ocaml-gettext:=[ocamlopt=]
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-ml/ocaml-fileutils[ocamlopt=]
+ dev-ml/ounit[ocamlopt=]
+ )
+"