summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-sha
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocaml-sha')
-rw-r--r--dev-ml/ocaml-sha/Manifest3
-rw-r--r--dev-ml/ocaml-sha/metadata.xml18
-rw-r--r--dev-ml/ocaml-sha/ocaml-sha-1.15.1.ebuild22
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-ml/ocaml-sha/Manifest b/dev-ml/ocaml-sha/Manifest
new file mode 100644
index 000000000000..ba81ae9c79b6
--- /dev/null
+++ b/dev-ml/ocaml-sha/Manifest
@@ -0,0 +1,3 @@
+DIST ocaml-sha-1.15.1.tar.gz 15972 BLAKE2B c80fe4ba9a216fb88b0ca4cdf4f467450ad7225c9aa8fbb7389c85b8372de0a965683dc4a674c82ae4c2801b9f6a83777fbd3bfe5deb68af3d5e9193c058c9d9 SHA512 25af4f3fff6d5126e5e3b5f4dff4d6cc48396ffea48da186450236825bbb79110c7918a2bfa1c77dfaee9570965f9052d87c513d9f9da01208d95962b12cfd1c
+EBUILD ocaml-sha-1.15.1.ebuild 518 BLAKE2B ae29ba7ce2e8e29bfdc689eb099f2db08c5b52044a319813df1bba676b12fee193b422669eb554c9d5d4a499c6d75fa1934dd0fa63b4568fa22d42a5fecd5fbc SHA512 ec054f2cfa156b9b910bb45eb11d7db42a82ec01d9196c9eb35a39bab495b74cf926f1b184b6d440dcdfa89a4d26ec1a62abcaf27c4d13d889a023aba38ab325
+MISC metadata.xml 648 BLAKE2B 4f14d64187eeb7bff8fd8c67242b0f6b5ee0779312522e3c7f5041d629861015923fe15b49fd1f4474f6a38558c176aa9fafb2bbbfc93c82f515705670660fd0 SHA512 c56c4732c21229b543af6313a2150fb5351ada4d85a8ff2071952e734338d59ed4432813f841e49982f8cbbf84d3ba69c7886109dd13051b5c5a5f9f1f22c3ba
diff --git a/dev-ml/ocaml-sha/metadata.xml b/dev-ml/ocaml-sha/metadata.xml
new file mode 100644
index 000000000000..34e9bead1fc0
--- /dev/null
+++ b/dev-ml/ocaml-sha/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <longdescription>
+ This is the binding for SHA interface code in OCaml. Offering the same
+ interface than the MD5 digest included in the OCaml standard library.
+ It's currently providing SHA1, SHA256 and SHA512 hash functions.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/djs55/ocaml-sha/issues/</bugs-to>
+ <remote-id type="github">djs55/ocaml-sha</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-sha/ocaml-sha-1.15.1.ebuild b/dev-ml/ocaml-sha/ocaml-sha-1.15.1.ebuild
new file mode 100644
index 000000000000..d6ab5623b0f4
--- /dev/null
+++ b/dev-ml/ocaml-sha/ocaml-sha-1.15.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DUNE_PKG_NAME="sha"
+
+inherit dune
+
+DESCRIPTION="Binding to the SHA cryptographic functions"
+HOMEPAGE="https://github.com/djs55/ocaml-sha"
+SRC_URI="https://github.com/djs55/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-ml/stdlib-shims:="
+DEPEND="${RDEPEND}"
+BDEPEND="test? ( dev-ml/ounit2 )"