summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-stdint/ocaml-stdint-0.7.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocaml-stdint/ocaml-stdint-0.7.2.ebuild')
-rw-r--r--dev-ml/ocaml-stdint/ocaml-stdint-0.7.2.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-ml/ocaml-stdint/ocaml-stdint-0.7.2.ebuild b/dev-ml/ocaml-stdint/ocaml-stdint-0.7.2.ebuild
new file mode 100644
index 000000000000..ea2718d47453
--- /dev/null
+++ b/dev-ml/ocaml-stdint/ocaml-stdint-0.7.2.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DUNE_PKG_NAME="stdint"
+
+inherit dune
+
+DESCRIPTION="Signed and unsigned integer types having specified widths"
+HOMEPAGE="https://github.com/andrenth/ocaml-stdint"
+SRC_URI="https://github.com/andrenth/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt"
+RESTRICT="test" # some tests fails