summaryrefslogtreecommitdiff
path: root/dev-ml/ocplib-endian
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocplib-endian')
-rw-r--r--dev-ml/ocplib-endian/Manifest4
-rw-r--r--dev-ml/ocplib-endian/metadata.xml11
-rw-r--r--dev-ml/ocplib-endian/ocplib-endian-1.1-r1.ebuild20
3 files changed, 30 insertions, 5 deletions
diff --git a/dev-ml/ocplib-endian/Manifest b/dev-ml/ocplib-endian/Manifest
index fc2faf175c94..782b3c422f32 100644
--- a/dev-ml/ocplib-endian/Manifest
+++ b/dev-ml/ocplib-endian/Manifest
@@ -1,3 +1,5 @@
DIST ocplib-endian-1.0.tar.gz 62753 BLAKE2B d343343eb22b7ff591219ad0d45502e3450cd4200d8f3cc7f8a4783bdd93752d015b686b57aa574f58344dc44cec751ba89e68f93770ca5df73a98d95a604b8d SHA512 a08fd58ec5e72510c40e8b75e0ee8327ee658f479e45dd4632bc04e3907d04aaa3684df3b993ab63fc2a6c1f1a4fb32784e9b5258730d3b89a716300522d8d7f
+DIST ocplib-endian-1.1.tar.gz 17544 BLAKE2B 62e4b1cb998ac00fd3cfd7178939b6c9f8c1bebe7c0dc072fbb45b79172cb07f4466e5f1e6e93b41e3fb8c3df8020d2033eb24abfec4906d3ad003fa22bdcd27 SHA512 39351c666d1394770696fa89ac62f7c137ad1697d99888bfba2cc8de2c61df05dd8b3aa327c117bf38f3e29e081026d2c575c5ad0022bde92b3d43aba577d3f9
EBUILD ocplib-endian-1.0.ebuild 567 BLAKE2B ecafe568edef8828f8a5828f272006f43a783ede73fcbfe5912c6e2f32d86a3d81b5b4fa03d901d5c7819308f6485eafe402d9296a75dd72381c65dae1411364 SHA512 9d7e7db49577d98be5d4a6b861c04766d12e3368bdcef29ac61c6a91471adfea49c638cdb633225fa6e5dd06e4c6862dceaaf85a04365a62667d0ede0214773c
-MISC metadata.xml 267 BLAKE2B 9dc41201846b7c37b0ae0f25c33c80565f84e3af99d0deb4d679469fa7e2916478064a82add297168e990b11d5fbc26716660d1d0a3f257f74929260cba5757a SHA512 a8bccbd85788cc5c7439bac9926948a657331d96367e99d4e9d3466b30a83a02bfd2f56be92a943840d0507f2cec8552853750e31d6b258976e4747188162ddf
+EBUILD ocplib-endian-1.1-r1.ebuild 540 BLAKE2B 0d822598889fa857b5061c51e83396bf8a3c7d4c7ee9dce532e329cffbacb19f49c9040eb502139de1dacb2b72b0e87edcd987316b528f0743e94a55d09501b0 SHA512 21544a29bda1adf0b3b11b5368cd143f246e4ad24c5f86c19be9c5aa9af6af43fc8a69e73277aaf1d4be4534809fe3f8abbfd9bd8d92a88cd7651158ea7c57b7
+MISC metadata.xml 331 BLAKE2B 99f5f2a85b64311e955383fbd71c64c917376f9b831a7edaf202ef4bfa0e613c64bc889099db33d5837d5c4bab28e77ae210e40597c30586b97b69fbc719b7b7 SHA512 8dc69602c2b6c4296a4d8c8777baa73b00a39b5b2d2893a9d4896d96595223bc9be74d01bdc9051852ba96e6157f7fe145d42fc5816cc6c53a3b548ea2681e30
diff --git a/dev-ml/ocplib-endian/metadata.xml b/dev-ml/ocplib-endian/metadata.xml
index 97705efc3173..79e925f71327 100644
--- a/dev-ml/ocplib-endian/metadata.xml
+++ b/dev-ml/ocplib-endian/metadata.xml
@@ -1,8 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
- <upstream>
- <remote-id type="github">OCamlPro/ocplib-endian</remote-id>
- </upstream>
+ <maintainer type="person">
+ <email>gienah@gentoo.org</email>
+ <name>Mark Wright</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">OCamlPro/ocplib-endian</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-ml/ocplib-endian/ocplib-endian-1.1-r1.ebuild b/dev-ml/ocplib-endian/ocplib-endian-1.1-r1.ebuild
new file mode 100644
index 000000000000..1cfb90194e02
--- /dev/null
+++ b/dev-ml/ocplib-endian/ocplib-endian-1.1-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Functions to read and write int16/32/64 from strings, bytes, and bigarrays"
+HOMEPAGE="https://github.com/OCamlPro/ocplib-endian"
+SRC_URI="https://github.com/OCamlPro/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+# 2 of 70 tests fail
+RESTRICT="test"
+
+BDEPEND=">=dev-ml/cppo-1.6.6"