summaryrefslogtreecommitdiff
path: root/dev-ml/ocurl/ocurl-0.7.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocurl/ocurl-0.7.9.ebuild')
-rw-r--r--dev-ml/ocurl/ocurl-0.7.9.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ml/ocurl/ocurl-0.7.9.ebuild b/dev-ml/ocurl/ocurl-0.7.9.ebuild
new file mode 100644
index 000000000000..978bdea229b6
--- /dev/null
+++ b/dev-ml/ocurl/ocurl-0.7.9.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="OCaml interface to the libcurl library"
+HOMEPAGE="http://forge.ocamlcore.org/projects/ocurl/ https://github.com/ygrek/ocurl"
+LICENSE="MIT"
+SRC_URI="https://github.com/ygrek/ocurl/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0/${PV}"
+IUSE="examples"
+
+RDEPEND=">=net-misc/curl-7.9.8
+ dev-ml/lwt:=
+ dev-ml/camlp4:=
+ >=dev-lang/ocaml-3.12:=[ocamlopt]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+
+src_compile()
+{
+ emake -j1 all
+}
+
+src_install()
+{
+ findlib_src_install
+ dodoc CHANGES.txt README.md
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}