summaryrefslogtreecommitdiff
path: root/dev-ml/opam-0install-cudf
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/opam-0install-cudf')
-rw-r--r--dev-ml/opam-0install-cudf/Manifest3
-rw-r--r--dev-ml/opam-0install-cudf/metadata.xml23
-rw-r--r--dev-ml/opam-0install-cudf/opam-0install-cudf-0.5.0.ebuild20
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-ml/opam-0install-cudf/Manifest b/dev-ml/opam-0install-cudf/Manifest
new file mode 100644
index 000000000000..9a590d984307
--- /dev/null
+++ b/dev-ml/opam-0install-cudf/Manifest
@@ -0,0 +1,3 @@
+DIST opam-0install-cudf-0.5.0.tar.gz 9327 BLAKE2B 705e0bcdd8311e5c330f37e5b05ccb02fa73e42603d0c574480c54101fb746a5d5b61176811dff9eaf09bac370f064dfb8a9ada8f4912586a79e7fccefd122ad SHA512 83c0372168d612ef80548ab7fb021a92cdc39e13a77d87c5af5fd21eb515389b624d09c24d500e9ac33b3fc10d17c9869f160f8771f9c8f545b0453b9a0fd4df
+EBUILD opam-0install-cudf-0.5.0.ebuild 423 BLAKE2B af71c5b62af5a3bd79d4a38c5f818fae730b53d2acb95bed90bfe0e3b6dbed44787f2e3aaa02723aa847d7b2026ba0fb8199c532c6ab1d665ead7c4fdefaee1a SHA512 bd59535f652dd111cf9e382c3542141a9f6f815b8a4b75d21f9e967464d808f15c08683917c6fe136dddffe843ce97384b6f07adb91bbef9a7cd8aea08bc8cb3
+MISC metadata.xml 953 BLAKE2B 2ca4d579e427e6e776cc59d700f918731565074bacabc6ab7dd11d81f7b40303b12aa58598f0ee2db84d87c4afeefb9da798d94a900463c1e19e898e441a3246 SHA512 b1d7791c6c88ee0f630bd544060c59fb8f5778b0bd9cd65fe0fe1bc48fc41e4cfa51c7a7cfc728ab6c7abcef274eb83a421214f617bf2f406abe74d20f4c9ba1
diff --git a/dev-ml/opam-0install-cudf/metadata.xml b/dev-ml/opam-0install-cudf/metadata.xml
new file mode 100644
index 000000000000..923f467c195e
--- /dev/null
+++ b/dev-ml/opam-0install-cudf/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <longdescription lang="en">
+ Opam's default solver is designed to maintain a set of packages over
+ time, minimising disruption when installing new programs and finding a
+ compromise solution across all packages.
+ In many situations (e.g. CI, local roots or duniverse builds) this is
+ not necessary, and we can get a solution much faster by using a
+ different algorithm.
+ This package provides a generic solver library which uses 0install's
+ solver library. The library uses the CUDF library in order to interface
+ with opam as it is the format common used to talk to all the supported
+ solvers.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">ocaml-opam/opam-0install-cudf</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/opam-0install-cudf/opam-0install-cudf-0.5.0.ebuild b/dev-ml/opam-0install-cudf/opam-0install-cudf-0.5.0.ebuild
new file mode 100644
index 000000000000..9db05d077373
--- /dev/null
+++ b/dev-ml/opam-0install-cudf/opam-0install-cudf-0.5.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Opam solver using 0install backend using the CUDF interface"
+HOMEPAGE="https://github.com/ocaml-opam/opam-0install-cudf"
+SRC_URI="https://github.com/ocaml-opam/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="+ocamlopt"
+
+src_configure() {
+ :
+}