summaryrefslogtreecommitdiff
path: root/dev-ml/ounit2/ounit2-2.2.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ounit2/ounit2-2.2.7.ebuild')
-rw-r--r--dev-ml/ounit2/ounit2-2.2.7.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ml/ounit2/ounit2-2.2.7.ebuild b/dev-ml/ounit2/ounit2-2.2.7.ebuild
new file mode 100644
index 000000000000..fa12658631a0
--- /dev/null
+++ b/dev-ml/ounit2/ounit2-2.2.7.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Unit testing framework for OCaml"
+HOMEPAGE="https://github.com/gildor478/ounit"
+SRC_URI="https://github.com/gildor478/ounit/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/ounit-${PV}"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ dev-ml/lwt:=
+ dev-ml/stdlib-shims:=
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-2.2.7-dune.patch" )
+
+src_install() {
+ dune-install ${PN} ${PN}-lwt
+}