summaryrefslogtreecommitdiff
path: root/dev-ml/parmap/parmap-1.0_rc7-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/parmap/parmap-1.0_rc7-r1.ebuild')
-rw-r--r--dev-ml/parmap/parmap-1.0_rc7-r1.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-ml/parmap/parmap-1.0_rc7-r1.ebuild b/dev-ml/parmap/parmap-1.0_rc7-r1.ebuild
deleted file mode 100644
index 442a609b95ea..000000000000
--- a/dev-ml/parmap/parmap-1.0_rc7-r1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit multilib
-
-MY_PV="${PV/_/-}-fix-for4.03+3"
-DESCRIPTION="Library to exploit multicore architectures for OCaml programs"
-HOMEPAGE="https://www.dicosmo.org/code/parmap/"
-SRC_URI="https://github.com/rdicosmo/parmap/archive/${MY_PV}.tar.gz -> ${P}-ocaml-4.03.tar.gz"
-
-LICENSE="LGPL-2-with-linking-exception"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="+ocamlopt"
-
-RDEPEND=">=dev-lang/ocaml-4.03:=[ocamlopt?]"
-DEPEND="${RDEPEND}
- dev-ml/findlib
- dev-ml/ocamlbuild
- dev-ml/ocaml-autoconf"
-S="${WORKDIR}/${PN}-${MY_PV/+/-}"
-
-src_test() {
- mkdir "${WORKDIR}/tmpinstall" || die
- emake \
- OCAMLLIBDIR="ocaml" \
- DESTDIR="${WORKDIR}/tmpinstall" \
- install
- export OCAMLPATH="${WORKDIR}/tmpinstall/ocaml"
- emake tests
- cd _build/tests || die
- for i in $(find . -type f -executable) ; do
- ${i} || die
- done
-}
-
-src_install() {
- emake \
- OCAMLLIBDIR="$(get_libdir)/ocaml" \
- MANDIR="${ED}/usr/share/man/man3o" \
- DESTDIR="${ED}/usr" \
- install
- dodoc AUTHORS Changelog README
-}