summaryrefslogtreecommitdiff
path: root/dev-ml/ppx_bin_prot/ppx_bin_prot-0.14.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ppx_bin_prot/ppx_bin_prot-0.14.0.ebuild')
-rw-r--r--dev-ml/ppx_bin_prot/ppx_bin_prot-0.14.0.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/dev-ml/ppx_bin_prot/ppx_bin_prot-0.14.0.ebuild b/dev-ml/ppx_bin_prot/ppx_bin_prot-0.14.0.ebuild
index 09c3fc426cd0..667f5d60f08c 100644
--- a/dev-ml/ppx_bin_prot/ppx_bin_prot-0.14.0.ebuild
+++ b/dev-ml/ppx_bin_prot/ppx_bin_prot-0.14.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -28,4 +28,15 @@ RDEPEND="
DEPEND="${RDEPEND}
test? (
dev-ml/ppx_jane
+ dev-ml/core
+ dev-ml/ounit2
+ dev-ml/core_bench
)"
+
+src_prepare() {
+ sed -i \
+ -e "s:oUnit:ounit2:" \
+ test/dune \
+ || die
+ default
+}