summaryrefslogtreecommitdiff
path: root/dev-ml/ppx_here/ppx_here-0.15.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ppx_here/ppx_here-0.15.0.ebuild')
-rw-r--r--dev-ml/ppx_here/ppx_here-0.15.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ml/ppx_here/ppx_here-0.15.0.ebuild b/dev-ml/ppx_here/ppx_here-0.15.0.ebuild
new file mode 100644
index 000000000000..b3c0a538d577
--- /dev/null
+++ b/dev-ml/ppx_here/ppx_here-0.15.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Expands [%here] into its location"
+HOMEPAGE="https://github.com/janestreet/ppx_here"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ dev-ml/base:${SLOT}
+ dev-ml/findlib:=
+ >=dev-ml/ppxlib-0.23.0:=
+ >=dev-ml/ocaml-compiler-libs-0.11.0:=
+"
+RDEPEND="${DEPEND}"
+
+# Error: No rule found for test/dummy.ml.pp
+RESTRICT=test