summaryrefslogtreecommitdiff
path: root/dev-ml/ppx_stable_witness/ppx_stable_witness-0.17.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ppx_stable_witness/ppx_stable_witness-0.17.0.ebuild')
-rw-r--r--dev-ml/ppx_stable_witness/ppx_stable_witness-0.17.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ml/ppx_stable_witness/ppx_stable_witness-0.17.0.ebuild b/dev-ml/ppx_stable_witness/ppx_stable_witness-0.17.0.ebuild
new file mode 100644
index 000000000000..9d18f27b5b7d
--- /dev/null
+++ b/dev-ml/ppx_stable_witness/ppx_stable_witness-0.17.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Ppx extension for deriving a witness that a type is intended to be stable"
+HOMEPAGE="https://github.com/janestreet/ppx_stable_witness"
+SRC_URI="https://github.com/janestreet/ppx_stable_witness/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ >=dev-lang/ocaml-5
+ dev-ml/base:${SLOT}[ocamlopt?]
+ >=dev-ml/ppxlib-0.32.1:=[ocamlopt?]
+"
+DEPEND="${RDEPEND}"
+BDEPEND=">=dev-ml/dune-3.11"