summaryrefslogtreecommitdiff
path: root/dev-ml/ptime/ptime-1.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ptime/ptime-1.0.0.ebuild')
-rw-r--r--dev-ml/ptime/ptime-1.0.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ml/ptime/ptime-1.0.0.ebuild b/dev-ml/ptime/ptime-1.0.0.ebuild
new file mode 100644
index 000000000000..49d8a2f7ff44
--- /dev/null
+++ b/dev-ml/ptime/ptime-1.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit opam findlib
+
+DESCRIPTION="POSIX time for OCaml"
+HOMEPAGE="
+ https://erratique.ch/software/ptime
+ https://github.com/dbuenzli/ptime
+ https://opam.ocaml.org/packages/ptime/
+"
+SRC_URI="https://erratique.ch/software/ptime/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=""
+DEPEND="
+ ${RDEPEND}
+ dev-ml/topkg
+"
+BDEPEND="dev-ml/ocamlbuild"
+
+OPAM_FILE=opam
+
+src_compile() {
+ ocaml pkg/pkg.ml build || die
+}