summaryrefslogtreecommitdiff
path: root/dev-ml/reason/reason-2.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/reason/reason-2.0.0.ebuild')
-rw-r--r--dev-ml/reason/reason-2.0.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ml/reason/reason-2.0.0.ebuild b/dev-ml/reason/reason-2.0.0.ebuild
new file mode 100644
index 000000000000..0fc83b36497d
--- /dev/null
+++ b/dev-ml/reason/reason-2.0.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit opam
+
+DESCRIPTION="Meta Language Toolchain"
+HOMEPAGE="https://github.com/facebook/reason"
+SRC_URI="https://github.com/facebook/reason/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+DEPEND="
+ dev-ml/reason-parser:=
+ dev-ml/merlin-extend:=
+ dev-ml/result:=
+ dev-ml/topkg:=
+ dev-ml/ocaml-migrate-parsetree:=
+ dev-ml/utop:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ dev-ml/findlib
+ dev-ml/ocamlbuild
+"
+
+src_compile() {
+ emake precompile
+ emake build
+}