summaryrefslogtreecommitdiff
path: root/dev-ml/result/result-1.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/result/result-1.2.ebuild')
-rw-r--r--dev-ml/result/result-1.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ml/result/result-1.2.ebuild b/dev-ml/result/result-1.2.ebuild
new file mode 100644
index 000000000000..8c8cb8d1cd21
--- /dev/null
+++ b/dev-ml/result/result-1.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit findlib
+
+DESCRIPTION="Compat result type"
+HOMEPAGE="https://github.com/janestreet/result"
+SRC_URI="https://github.com/janestreet/result/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="+ocamlopt"
+
+RDEPEND="dev-lang/ocaml:=[ocamlopt?]"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake byte
+ use ocamlopt && emake native
+}
+
+src_install() {
+ findlib_src_install
+ dodoc README.md
+}