summaryrefslogtreecommitdiff
path: root/dev-ml/sexplib/sexplib-0.9.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/sexplib/sexplib-0.9.3.ebuild')
-rw-r--r--dev-ml/sexplib/sexplib-0.9.3.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ml/sexplib/sexplib-0.9.3.ebuild b/dev-ml/sexplib/sexplib-0.9.3.ebuild
new file mode 100644
index 000000000000..a5ed48014b30
--- /dev/null
+++ b/dev-ml/sexplib/sexplib-0.9.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit opam
+
+DESCRIPTION="Library for automated conversion of OCaml-values to and from S-expressions"
+HOMEPAGE="https://github.com/janestreet/sexplib"
+SRC_URI="https://github.com/janestreet/sexplib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND} dev-ml/jbuilder"
+
+src_test() {
+ jbuilder runtest || die
+}