summaryrefslogtreecommitdiff
path: root/dev-ml/stdcompat/stdcompat-19-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/stdcompat/stdcompat-19-r2.ebuild')
-rw-r--r--dev-ml/stdcompat/stdcompat-19-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ml/stdcompat/stdcompat-19-r2.ebuild b/dev-ml/stdcompat/stdcompat-19-r2.ebuild
new file mode 100644
index 000000000000..fd7184f8ab04
--- /dev/null
+++ b/dev-ml/stdcompat/stdcompat-19-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Compatibility module for OCaml standard library"
+HOMEPAGE="https://github.com/thierry-martinez/stdcompat"
+SRC_URI="https://github.com/thierry-martinez/stdcompat/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="<dev-lang/ocaml-5:=[ocamlopt]
+ dev-ml/result:=[ocamlopt]
+ dev-ml/uchar:=[ocamlopt]"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-ml/dune
+ dev-ml/findlib[ocamlopt]"
+
+# Do not complain about CFLAGS etc since ml projects do not use them.
+QA_FLAGS_IGNORED='.*'
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure () {
+ econf --libdir="${EPREFIX}"/usr/$(get_libdir)/ocaml
+}