summaryrefslogtreecommitdiff
path: root/dev-ml/yojson/yojson-1.4.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/yojson/yojson-1.4.0.ebuild')
-rw-r--r--dev-ml/yojson/yojson-1.4.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/yojson/yojson-1.4.0.ebuild b/dev-ml/yojson/yojson-1.4.0.ebuild
new file mode 100644
index 000000000000..e3b9f39c5175
--- /dev/null
+++ b/dev-ml/yojson/yojson-1.4.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib opam
+
+DESCRIPTION="JSON parsing and pretty-printing library for OCaml"
+HOMEPAGE="http://mjambon.com/yojson.html https://github.com/mjambon/yojson"
+SRC_URI="https://github.com/mjambon/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0/${PV}"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+RDEPEND=">=dev-lang/ocaml-3.11:=[ocamlopt]
+ dev-ml/easy-format:=[ocamlopt]
+ >=dev-ml/biniou-1.2:=[ocamlopt]
+"
+DEPEND="${RDEPEND}
+ dev-ml/cppo
+ dev-ml/jbuilder
+"
+
+src_install() {
+ opam_src_install
+
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}